Bug 997994 - Double quote character as password attempt causes "We're sorry, but something went wrong."
Double quote character as password attempt causes "We're sorry, but something...
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Infrastructure (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Marek Hulan
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-16 13:40 EDT by Jeff Weiss
Modified: 2014-11-09 17:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 13:14:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Weiss 2013-08-16 13:40:12 EDT
Description of problem:


Version-Release number of selected component (if applicable):
1.4.3-1.git.222.3b1f9e0.el6

How reproducible:


Steps to Reproduce:
1. Login as admin with password being just a doublequote character "
2. 
3.

Actual results:
We're sorry, but something went wrong.

Expected results:
Invalid credentials

Additional info:
Comment 1 RHEL Product and Program Management 2013-09-17 00:17:45 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 4 Marek Hulan 2013-09-25 11:14:40 EDT
I'm not able to reproduce. I tried password like "test and it worked. I can't set just " because of length validation. Could you please provide a log from katello and signo when you run it in debug logging level?
Comment 5 Jeff Weiss 2013-10-01 13:14:42 EDT
I cannot repro either now, looks like it was fixed indirectly. 1.4.7-1.git.15.71ec0ee.el6
Comment 6 Mike McCune 2014-01-16 16:16:55 EST
removing signo component and moving these bugs to 'Infrastructure'

Note You need to log in before you can comment on or make changes to this bug.