Bug 998012 - when /tmp is full services fail over
when /tmp is full services fail over
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: resource-agents (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity medium
: rc
: 6.6
Assigned To: David Vossel
Cluster QE
:
Depends On: 997546
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-16 14:10 EDT by Ryan McCabe
Modified: 2015-08-24 02:35 EDT (History)
9 users (show)

See Also:
Fixed In Version: resource-agents-3.9.2-33.el6
Doc Type: Bug Fix
Doc Text:
Cause: Filesystem based resources, such as fs.sh and clusterfs.sh, required usage of the /tmp directory during status monitoring. If the /tmp directory became full after mounting the filesystem, the monitor action would fail even though the filesystem is correctly mounted. Consequence: Healthy mounted filesystems failover because the /tmp directory is full. Fix: We no longer make use of the /tmp directory during filesystem monitors. Result: Filesystem monitors do not fail if the /tmp directory is full.
Story Points: ---
Clone Of: 997546
Environment:
Last Closed: 2013-11-21 00:21:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 454393 None None None Never

  None (edit)
Comment 8 michal novacek 2013-09-17 11:21:46 EDT
I checked that the resource will not move after the /tmp filesystem is full.

virt-036 # rpm -q resource-agents
resource-agents-3.9.2-33.el6.x86_64

virt-036 # ccs -f /etc/cluster/cluster.conf --lsservices
service: name=ha-fs, domain=le-domain, recovery=relocate
  fs: ref=ha-fs
resources: 
  fs: name=ha-fs, self_fence=1, force_unmount=1, fstype=ext4, device=/dev/ha-vg/ha-lv-0, mountpoint=/exports, fsid=25315

virt-036 # clustat
Cluster Status for STSRHTS11207 @ Tue Sep 17 17:04:05 2013
Member Status: Quorate

 Member Name                       ID   Status
 ------ ----                       ---- ------
 virt-035                          1 Online, rgmanager
 virt-036                          2 Online, Local, rgmanager
 virt-037                          3 Online, rgmanager

 Service Name       Owner (Last)                   State         
 ------- ----       ----- ------                   -----         
 service:ha-fs      virt-036                       started       

virt-036 # mount  | grep exports
/dev/mapper/ha--vg-ha--lv--0 on /exports type ext4 (rw)

virt-036 # dd if=/dev/zero of=/tmp/bigfile
dd: writing to `/tmp/bigfile': No space left on device
9226177+0 records in
9226176+0 records out
4723802112 bytes (4.7 GB) copied, 33.6405 s, 140 MB/s

virt-036 # clustat
Cluster Status for STSRHTS11207 @ Tue Sep 17 17:07:22 2013
Member Status: Quorate

 Member Name                       ID   Status
 ------ ----                       ---- ------
 virt-035                          1 Online, rgmanager
 virt-036                          2 Online, Local, rgmanager
 virt-037                          3 Online, rgmanager

 Service Name       Owner (Last)                   State         
 ------- ----       ----- ------                   -----         
 service:ha-fs      virt-036                       started       

virt-036 # mount | grep exports
/dev/mapper/ha--vg-ha--lv--0 on /exports type ext4 (rw)
Comment 10 errata-xmlrpc 2013-11-21 00:21:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1541.html

Note You need to log in before you can comment on or make changes to this bug.