Bug 998026 - oo-admin-cartridge -a erase does not erase
Summary: oo-admin-cartridge -a erase does not erase
Status: CLOSED DUPLICATE of bug 991387
Alias: None
Product: OKD
Classification: Red Hat
Component: Containers (Show other bugs)
(Show other bugs)
Version: 2.x
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Jhon Honce
QA Contact: libra bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-08-16 18:50 UTC by Miciah Dashiel Butler Masters
Modified: 2015-05-14 23:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-17 02:11:33 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Miciah Dashiel Butler Masters 2013-08-16 18:50:00 UTC
Description of problem:
Cartridges show up in the output of `oo-admin-cartridge -a list` even after I've removed them using `oo-admin-cartridge -a erase`.


Version-Release number of selected component (if applicable):
Origin HEAD.


How reproducible:
Tried with three cartridges.


Steps to Reproduce:
1. Run `oo-admin-cartridge -a list`.
2. Run `oo-admin-cartridge -a erase -n cron -v 1.4 -c 0.0.4`.
3. Run `oo-admin-cartridge -a list` again.


Actual results:
# oo-admin-cartridge -a list
(redhat, diy, 0.1, 0.0.3)
(redhat, php, 5.3, 0.0.3)
(redhat, mongodb, 2.2, 0.2.1)
(redhat, jbossas, 7, 0.0.4)
(redhat, cron, 1.4, 0.0.4)
(redhat, perl, 5.10, 0.0.3)
(redhat, mock, 0.1, 0.0.1)
(redhat, mock, 0.2, 0.0.1)
(redhat, zend, 5.6, 0.0.3)
(redhat, jenkins, 1, 0.0.3)
(redhat, phpmyadmin, 3, 0.0.3)
(redhat, nodejs, 0.6, 0.0.3)
(redhat, haproxy, 1.4, 0.0.4)
(redhat, jbossews, 1.0, 0.0.4)
(redhat, jbossews, 2.0, 0.0.4)
(redhat, mock-plugin, 0.1, 0.0.1)
(redhat, jbosseap, 6, 0.0.4)
(redhat, 10gen-mms-agent, 0.1, 0.0.2)
(redhat, python, 2.6, 0.0.4)
(redhat, python, 2.7, 0.0.4)
(redhat, python, 3.3, 0.0.4)
(redhat, postgresql, 8.4, 0.3.1)
(redhat, postgresql, 9.2, 0.3.1)
(redhat, switchyard, 0, 0.0.3)
(redhat, ruby, 1.8, 0.0.5)
(redhat, ruby, 1.9, 0.0.5)
(redhat, metrics, 0.1, 0.0.2)
(redhat, jenkins-client, 1, 0.0.2)
(redhat, mysql, 5.1, 0.2.1)
(redhat, rockmongo, 1.1, 0.0.2)
# oo-admin-cartridge -a erase -n cron -v 1.4 -c 0.0.4
succeeded
# oo-admin-cartridge -a list
(redhat, diy, 0.1, 0.0.3)
(redhat, php, 5.3, 0.0.3)
(redhat, mongodb, 2.2, 0.2.1)
(redhat, jbossas, 7, 0.0.4)
(redhat, cron, 1.4, 0.0.4)
(redhat, perl, 5.10, 0.0.3)
(redhat, mock, 0.1, 0.0.1)
(redhat, mock, 0.2, 0.0.1)
(redhat, zend, 5.6, 0.0.3)
(redhat, jenkins, 1, 0.0.3)
(redhat, phpmyadmin, 3, 0.0.3)
(redhat, nodejs, 0.6, 0.0.3)
(redhat, haproxy, 1.4, 0.0.4)
(redhat, jbossews, 1.0, 0.0.4)
(redhat, jbossews, 2.0, 0.0.4)
(redhat, mock-plugin, 0.1, 0.0.1)
(redhat, jbosseap, 6, 0.0.4)
(redhat, 10gen-mms-agent, 0.1, 0.0.2)
(redhat, python, 2.6, 0.0.4)
(redhat, python, 2.7, 0.0.4)
(redhat, python, 3.3, 0.0.4)
(redhat, postgresql, 8.4, 0.3.1)
(redhat, postgresql, 9.2, 0.3.1)
(redhat, switchyard, 0, 0.0.3)
(redhat, ruby, 1.8, 0.0.5)
(redhat, ruby, 1.9, 0.0.5)
(redhat, metrics, 0.1, 0.0.2)
(redhat, jenkins-client, 1, 0.0.2)
(redhat, mysql, 5.1, 0.2.1)
(redhat, rockmongo, 1.1, 0.0.2)


Expected results:
The line "(redhat, cron, 1.4, 0.0.4)" should be gone from the output of `oo-admin-cartridge -a list` after Step 3.

Comment 1 Xiaoli Tian 2013-08-17 02:05:22 UTC
According to https://bugzilla.redhat.com/show_bug.cgi?id=991387#c1

Erase will only remove versions of cartridges not included in /usr/libexec/openshift/cartridges

Comment 2 Miciah Dashiel Butler Masters 2013-08-17 02:11:33 UTC
I see.  Thanks!

*** This bug has been marked as a duplicate of bug 991387 ***


Note You need to log in before you can comment on or make changes to this bug.