Bug 998136 - soffice.bin segfault in libvclplug_gtklo.so killed by signal 11 (SIGSEGV)
soffice.bin segfault in libvclplug_gtklo.so killed by signal 11 (SIGSEGV)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
19
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-17 12:19 EDT by Henrique Martins
Modified: 2013-08-28 09:35 EDT (History)
7 users (show)

See Also:
Fixed In Version: libreoffice-4.1.1.1-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-28 09:35:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
abrt report (135.50 KB, text/plain)
2013-08-19 12:22 EDT, Henrique Martins
no flags Details

  None (edit)
Description Henrique Martins 2013-08-17 12:19:19 EDT
Description of problem:
oocalc crashes anytime I try to format cells, be it via the pull down menu or from right click.


Version-Release number of selected component (if applicable):
libreoffice-4.1.0.4-6.fc19.x86_64

How reproducible:
Always

Steps to Reproduce:
1. run oocalc
2. open any file
3. try to format/cells

Actual results:
puff, core dump

Expected results:
running as before

Additional info:
Have abrt dumps, if needed
Comment 1 Caolan McNamara 2013-08-19 04:03:06 EDT
please provide the abrt dumps because if it was as simple as format cells crashes for everyone (and it doesn't for me) then we would have noticed that by now. This could be related to e.g. a specific font you have installed.
Comment 2 Henrique Martins 2013-08-19 12:22:50 EDT
Created attachment 788151 [details]
abrt report

Abrt report.  Let me know if something else is needed.
Comment 3 Henrique Martins 2013-08-19 13:13:24 EDT
This always fails on two of the systems where I have the nvidia driver, works fine on machines where I don't ...
Comment 4 Caolan McNamara 2013-08-20 09:15:55 EDT
The crashing line is
    gint xthickness = gWidgetData[0].gNotebookWidget->style->xthickness;
Comment 5 Caolan McNamara 2013-08-20 09:16:59 EDT
are the crashing system multihead ?
Comment 6 Henrique Martins 2013-08-20 10:27:45 EDT
Now that you mentioned, yes, both systems are multiheaded and it only crashes on :0.1 works fine on :0.0!
Comment 7 Caolan McNamara 2013-08-20 15:01:23 EDT
excellent, that's the exact problem. Will be fixed in the next update
Comment 8 Henrique Martins 2013-08-28 09:15:11 EDT
4.1.1.2-2.fc19 just came across, and it seems to fix this bug

Note You need to log in before you can comment on or make changes to this bug.