Bug 998148 - DeviceError: ('cannot replace active format', 'sda2')
DeviceError: ('cannot replace active format', 'sda2')
Status: CLOSED DUPLICATE of bug 1114786
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:5c8aa4ef6a7971773c591270df9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-17 13:41 EDT by kerhunet
Modified: 2014-10-13 09:42 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-13 09:42:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (831.81 KB, text/plain)
2013-08-17 13:41 EDT, kerhunet
no flags Details
File: anaconda.log (66.40 KB, text/plain)
2013-08-17 13:41 EDT, kerhunet
no flags Details
File: environ (519 bytes, text/plain)
2013-08-17 13:41 EDT, kerhunet
no flags Details
File: lsblk_output (2.50 KB, text/plain)
2013-08-17 13:41 EDT, kerhunet
no flags Details
File: messages (341.97 KB, text/plain)
2013-08-17 13:42 EDT, kerhunet
no flags Details
File: nmcli_dev_list (10.64 KB, text/plain)
2013-08-17 13:42 EDT, kerhunet
no flags Details
File: os_info (179 bytes, text/plain)
2013-08-17 13:42 EDT, kerhunet
no flags Details
File: program.log (75.02 KB, text/plain)
2013-08-17 13:42 EDT, kerhunet
no flags Details
File: storage.log (255.00 KB, text/plain)
2013-08-17 13:42 EDT, kerhunet
no flags Details
File: ifcfg.log (1.75 KB, text/plain)
2013-08-17 13:42 EDT, kerhunet
no flags Details
anaconda-tb-knJHFl (752.90 KB, text/plain)
2013-08-30 03:19 EDT, Steve Tyler
no flags Details

  None (edit)
Description kerhunet 2013-08-17 13:41:32 EDT
Version-Release number of selected component:
anaconda-19.30.13-1.fc19.x86_64

The following was filed automatically by anaconda:
anaconda 19.30.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 913, in _setFormat
    raise DeviceError("cannot replace active format", self.name)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 1400, in _setFormat
    StorageDevice._setFormat(self, format)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 922, in <lambda>
    lambda d,f: d._setFormat(f),
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1473, in _save_right_side
    device.format = old_format
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2756, in on_apply_clicked
    self._save_right_side(self._current_selector)
DeviceError: ('cannot replace active format', 'sda2')

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang fr_FR.utf8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-19-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-blivet-0.17-1.fc19.noarch
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19
Comment 1 kerhunet 2013-08-17 13:41:47 EDT
Created attachment 787593 [details]
File: anaconda-tb
Comment 2 kerhunet 2013-08-17 13:41:52 EDT
Created attachment 787594 [details]
File: anaconda.log
Comment 3 kerhunet 2013-08-17 13:41:55 EDT
Created attachment 787595 [details]
File: environ
Comment 4 kerhunet 2013-08-17 13:41:59 EDT
Created attachment 787596 [details]
File: lsblk_output
Comment 5 kerhunet 2013-08-17 13:42:06 EDT
Created attachment 787597 [details]
File: messages
Comment 6 kerhunet 2013-08-17 13:42:10 EDT
Created attachment 787598 [details]
File: nmcli_dev_list
Comment 7 kerhunet 2013-08-17 13:42:14 EDT
Created attachment 787599 [details]
File: os_info
Comment 8 kerhunet 2013-08-17 13:42:18 EDT
Created attachment 787600 [details]
File: program.log
Comment 9 kerhunet 2013-08-17 13:42:25 EDT
Created attachment 787601 [details]
File: storage.log
Comment 10 kerhunet 2013-08-17 13:42:29 EDT
Created attachment 787602 [details]
File: ifcfg.log
Comment 11 Steve Tyler 2013-08-19 11:09:29 EDT
Thanks for your report.

Your system has 1 GB memory, which should be enough to install from the Live image without any swap, but the kernel says it ran out of memory while trying to disable swap.

Have you run a memory test and a media test?
(Both are under the Troubleshooting menu on the Live image.)

Snippet from attached anaconda.log:
...
17:07:43,369 INFO anaconda: 1048576 kB (1024 MB) are available
...

Snippet from attached messages: ("oom" means "Out Of Memory")
...
Aug 17 13:08:59 localhost kernel: [10858.022047] swapoff invoked oom-killer: gfp_mask=0x200da, order=0, oom_score_adj=0
...

Tested with:
$ qemu-img create f19-test-4.img 12G
Formatting 'f19-test-4.img', fmt=raw size=12884901888 

$ qemu-kvm -m 1024 -hda f19-test-4.img -cdrom ~/xfr/fedora/F19/Fedora-Live-Desktop-x86_64-19-1.iso -vga std -boot menu=on
Comment 12 kerhunet 2013-08-28 12:39:06 EDT
Hello,

sorry for the time before answer but i was travel for the last week.

The media test (at the boot) and memory test was ok.

When i launch a second time the install all was ok.

I think i was made many time different choice for the partition for install. May be it's come to go in and out many time to the partion assistant?

(i hope you understand cause i don't speak english well)
Comment 13 Steve Tyler 2013-08-30 03:13:50 EDT
Attempt to reproduce Bug 998148.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-19-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-blivet-0.17-1.fc19.noarch
package:        anaconda-19.30.13-1.fc19.x86_64
product:        Fedora
reason:         DeviceError: ('cannot replace active format', 'sda2')
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19
Comment 14 Steve Tyler 2013-08-30 03:19:12 EDT
Created attachment 792057 [details]
anaconda-tb-knJHFl
Comment 15 Steve Tyler 2013-08-30 04:05:34 EDT
Thanks for confirming that your install media and memory both pass their tests.

After looking again at your logs, I found that these packages had been installed in the Live environment:
gnome-shell-extension-common-3.8.3.1-1.fc19.noarch
gnome-shell-extension-user-theme-3.8.3.1-1.fc19.noarch
gnome-tweak-tool-3.8.1-1.fc19.noarch

After those were installed, gnome-tweak-tool was used to install two extensions:
remove-rounded-corners
hidetopbar
(again, following your logs)

After that, "free" and "top" showed that swap was being used.

I also ran "sudo yum update", which failed with numerous
"write error" and
"write errorbuilding deltarpms>"
messages.

After that, swap usage had increased to about 600 MB.

To reproduce the exception, I reformatted pre-existing partitions[1] as part of storage configuration in the Manual Partitioning dialog.

In a first attempt to reproduce, I did not reformat swap, and the install succeeded.

In a second attempt, I reformatted swap, and the install failed with the exception:
DeviceError: ('cannot replace active format', 'sda2')

Tested with:
$ qemu-img create f19-test-3.img 32G
Formatting 'f19-test-3.img', fmt=raw size=34359738368 

Pre-partition f19-test-3.img with gparted.

$ qemu-kvm -m 1024 -hda f19-test-3.img -cdrom ~/xfr/fedora/F19/Fedora-Live-Desktop-x86_64-19-1.iso -vga std -boot menu=on

[1] sda was pre-partitioned with gparted in an installed F19 system:
$ sudo parted /dev/sda u mib p free
Model: ATA QEMU HARDDISK (scsi)
Disk /dev/sda: 32768MiB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start     End       Size      Type     File system     Flags
        0.03MiB   1.00MiB   0.97MiB            Free Space
 1      1.00MiB   2001MiB   2000MiB   primary  ext2
 2      2001MiB   6001MiB   4000MiB   primary  linux-swap(v1)
 3      6001MiB   18001MiB  12000MiB  primary  ext4
 4      18001MiB  32768MiB  14767MiB  primary  ext4
Comment 16 David Shea 2014-10-13 09:42:49 EDT

*** This bug has been marked as a duplicate of bug 1114786 ***

Note You need to log in before you can comment on or make changes to this bug.