Bug 998175 - Glamor and radeonsi corrupted display with cursor
Glamor and radeonsi corrupted display with cursor
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11-glamor (Show other bugs)
20
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jérôme Glisse
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-17 18:54 EDT by Raman Gupta
Modified: 2014-11-23 19:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-23 19:56:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log (56.04 KB, text/x-log)
2013-08-17 18:54 EDT, Raman Gupta
no flags Details
glxinfo with LIBGL_DEBUG=verbose (29.64 KB, text/x-log)
2013-08-17 18:55 EDT, Raman Gupta
no flags Details

  None (edit)
Description Raman Gupta 2013-08-17 18:54:51 EDT
Created attachment 787670 [details]
Xorg log

I am trying to use the open source radeon driver to run a couple of Radeon HD 7950 (Tahiti, AMD Southern Islands chipset) cards.

# lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti PRO [Radeon HD 7950]
02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti PRO [Radeon HD 7950]

My xorg.conf works, if the dri2 and glamoregl modules are not loaded, so that X falls back to software rendering:

$ LIBGL_DEBUG=verbose glxinfo
name of display: :0
libGL: screen 0 does not appear to be DRI2 capable
libGL: OpenDriver: trying /usr/lib64/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib64/dri/swrast_dri.so
[...]
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.3, 256 bits)
OpenGL version string: 2.1 Mesa 9.2.0-devel  

(entire output will be attached)

However, when I enable dri2/glamoregl in xorg.conf (via the xorg-x11-glamor package), when X starts and the kdm login screen should be displayed, all monitors are mostly black with some corrupted areas. The cursor is visible.

X has started because I can type in my password and hit enter to bypass kdm and login, but the screen remains corrupted.

The xorg.0.log contains nothing obvious in terms of problems or crashes. I have attached it.

Kernel mode-setting is on (or at least I have done nothing explicit to enable or disable it, and I believe it is enabled by default).

Version-Release number of selected component (if applicable):

Name        : xorg-x11-server-Xorg
Version     : 1.14.2
Release     : 9.fc19

Name        : xorg-x11-drv-ati
Version     : 7.1.0
Release     : 5.20130408git6e74aacc5.fc19

Name        : xorg-x11-glamor
Version     : 0.5.0
Release     : 5.20130401git81aadb8.fc19

This happens every time X starts.

# lsmod  | grep radeon
radeon                844871  3 
i2c_algo_bit           13257  1 radeon
drm_kms_helper         50210  1 radeon
ttm                    80402  1 radeon
drm                   272504  5 ttm,drm_kms_helper,radeon
i2c_core               34242  6 drm,i2c_i801,drm_kms_helper,i2c_algo_bit,radeon,videodev

# cat /proc/fb 
0 radeondrmfb
1 radeondrmfb
Comment 1 Raman Gupta 2013-08-17 18:55:41 EDT
Created attachment 787671 [details]
glxinfo with LIBGL_DEBUG=verbose
Comment 2 Raman Gupta 2013-10-15 19:20:14 EDT
Latest FC19 xorg update, still the same error:

Name        : xorg-x11-server-Xorg
Version     : 1.14.3
Release     : 1.fc19

Versions of drv-ati and glamor have not changed.
Comment 3 Raman Gupta 2014-02-21 18:42:32 EST
Latest FC19 xorg update, still the same error:

Name        : xorg-x11-server-Xorg
Version     : 1.14.4
Release     : 3.fc19

Versions of drv-ati and glamor have not changed.
Comment 4 Raman Gupta 2014-02-22 01:59:25 EST
Bug seems to fixed using glamor and radeon driver from F20.
Comment 5 Raman Gupta 2014-11-04 11:18:52 EST
(In reply to Raman Gupta from comment #4)
> Bug seems to fixed using glamor and radeon driver from F20.

This was an error -- the problem is not fixed. When I reboot the machine, when X starts, it starts in the manner described (black screen mostly, some corrupted areas showing what appears to be past graphics data in video memory, mouse cursor active).

However, if I hit Ctrl-Alt-Delete 5-10 times I eventually get a perfectly working X session. Weird!

My current RPM versions on Fedora 20 are:

Name        : xorg-x11-server-Xorg
Version     : 1.14.4
Release     : 11.fc20

Name        : xorg-x11-drv-ati
Version     : 7.2.0
Release     : 3.20131101git3b38701.fc20

Name        : xorg-x11-glamor
Version     : 0.5.1
Release     : 3.20140115gitfb4d046c.fc20
Comment 6 Raman Gupta 2014-11-04 11:19:52 EST
(In reply to Raman Gupta from comment #5)
> However, if I hit Ctrl-Alt-Delete

That should have been Ctrl-Alt-Backspace of course -- to restart X.
Comment 7 Raman Gupta 2014-11-23 19:56:22 EST
Woot, this finally seems to be fixed in Fedora 21 alpha:

Name        : xorg-x11-server-Xorg
Version     : 1.16.1
Release     : 1.fc21

Name        : xorg-x11-drv-ati
Version     : 7.5.0
Release     : 1.fc21

Note that it was really borked in Fedora 20 with the latest mesa updates (10.3.3), with me getting the following error in my Xorg.0.log:

[    25.045] (II) AIGLX: Loaded and initialized radeonsi
[    25.045] (II) GLX: Initialized DRI2 GL provider for screen 0
[    25.147] (EE) 
Fatal server error:
[    25.147] (EE) destination is framebuffer incomplete: incomplete/missing attachment [8cd7]
[    25.147] (EE) 
[    25.147] (EE) 
Please consult the Fedora Project support 
         at http://wiki.x.org
 for help. 
[    25.147] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    25.147] (EE) 
[    25.147] (II) AIGLX: Suspending AIGLX clients for VT switch
[    25.218] (EE) Server terminated with error (1). Closing log file.

Note You need to log in before you can comment on or make changes to this bug.