Bug 998193 - SELinux is preventing java from creating .icedtea
SELinux is preventing java from creating .icedtea
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-18 01:17 EDT by Larry O'Leary
Modified: 2013-08-21 20:55 EDT (History)
3 users (show)

See Also:
Fixed In Version: selinux-policy-3.12.1-71.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-21 20:55:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larry O'Leary 2013-08-18 01:17:50 EDT
Description of problem:
Java applets will not execute due to SELinux. It appears that java is unable to create the .icedtea directory in the users home:

avc:  denied  { create } comm="java" name=".icedtea" scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=dir

Version-Release number of selected component (if applicable):
3.12.1.69-fc19

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora 19 + GNOME + Firefox + OpenJDK + icedtea-web
2. From Firefox, navigate to http://www.java.com/en/download/testjava.jsp

Actual results:
Java test applet exception occurs and SELinux denial is reported.

Expected results:
Java test applet should run normally and no SELinux denial should occur.

Additional info:
This looks like it might be a regression as this seems to have been reported a few different time over the past few months
Comment 2 Fedora Update System 2013-08-20 04:28:26 EDT
selinux-policy-3.12.1-71.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/selinux-policy-3.12.1-71.fc19
Comment 3 Fedora Update System 2013-08-20 20:17:15 EDT
Package selinux-policy-3.12.1-71.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.12.1-71.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15088/selinux-policy-3.12.1-71.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-08-21 20:55:08 EDT
selinux-policy-3.12.1-71.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.