Bug 998252 - [abrt] WARNING: at drivers/pci/pci.c:1393 pci_disable_device+0x85/0x90()
[abrt] WARNING: at drivers/pci/pci.c:1393 pci_disable_device+0x85/0x90()
Status: CLOSED DUPLICATE of bug 968058
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:a2d3bbb5586023df908cb8ee42e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-18 11:59 EDT by Leon
Modified: 2013-09-20 14:53 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-20 14:53:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (78.83 KB, text/plain)
2013-08-18 11:59 EDT, Leon
no flags Details

  None (edit)
Description Leon 2013-08-18 11:59:47 EDT
Additional info:
reporter:       libreport-2.1.5
WARNING: at drivers/pci/pci.c:1393 pci_disable_device+0x85/0x90()
Device e100
disabling already-disabled device
Modules linked in: nls_utf8 udf ipt_MASQUERADE nf_conntrack_netbios_ns nf_conntrack_broadcast bnep bluetooth ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables arc4 iTCO_wdt iTCO_vendor_support ppdev snd_usb_audio snd_usbmidi_lib rt73usb snd_intel8x0 snd_ac97_codec snd_hwdep snd_rawmidi rt2x00usb ac97_bus snd_seq rt2x00lib snd_seq_device mperf mac80211 snd_pcm cfg80211 microcode snd_page_alloc snd_timer serio_raw gspca_zc3xx snd rfkill gspca_main crc_itu_t soundcore videodev media lpc_ich mfd_core i2c_i801 e100 mii parport_pc parport uinput binfmt_misc nouveau mxm_wmi wmi video i2c_algo_bit drm_kms_helper ttm drm i2c_core
CPU: 0 PID: 3277 Comm: kworker/u4:53 Not tainted 3.10.4-100.fc18.i686.PAE #1
Hardware name: Mustek6376 mst6376                      /D845GRG                        , BIOS RG84510A.86A.0031.P16.0304111002 04/11/2003
Workqueue: events_unbound async_run_entry_fn
 f3d3fdec f3d3fdec f3d3fdb4 c09a4011 f3d3fddc c044bbf4 c0b8c7ec f3d3fe08
 00000571 c06b0ef5 c06b0ef5 f4930800 f4930800 f3d3fe3b f3d3fdf4 c044bcb3
 00000009 f3d3fdec c0b8c7ec f3d3fe08 f3d3fe10 c06b0ef5 c0b6cd10 00000571
Call Trace:
 [<c09a4011>] dump_stack+0x16/0x18
 [<c044bbf4>] warn_slowpath_common+0x64/0x80
 [<c06b0ef5>] ? pci_disable_device+0x85/0x90
 [<c06b0ef5>] ? pci_disable_device+0x85/0x90
 [<c044bcb3>] warn_slowpath_fmt+0x33/0x40
 [<c06b0ef5>] pci_disable_device+0x85/0x90
 [<f7e925a6>] __e100_shutdown+0x86/0x120 [e100]
 [<c06b3290>] ? pci_pm_restore_noirq+0xb0/0xb0
 [<f7e926b6>] e100_suspend+0x16/0x50 [e100]
 [<c06b2965>] pci_legacy_suspend+0x35/0xc0
 [<c09a87d5>] ? wait_for_completion+0x25/0xd0
 [<c06b3290>] ? pci_pm_restore_noirq+0xb0/0xb0
 [<c06b331c>] pci_pm_freeze+0x8c/0xb0
 [<c06b3290>] ? pci_pm_restore_noirq+0xb0/0xb0
 [<c077aeab>] dpm_run_callback+0x3b/0x90
 [<c077d584>] ? pm_wakeup_pending+0xc4/0x140
 [<c077afc2>] __device_suspend+0xc2/0x200
 [<c077b7ff>] async_suspend+0x1f/0x90
 [<c0472e5b>] async_run_entry_fn+0x3b/0x150
 [<c047b22f>] ? wake_up_process+0x1f/0x40
 [<c04661d9>] process_one_work+0x119/0x370
 [<c0467386>] worker_thread+0xf6/0x310
 [<c0467290>] ? manage_workers.isra.24+0x270/0x270
 [<c046c604>] kthread+0x94/0xa0
 [<c09b07b7>] ret_from_kernel_thread+0x1b/0x28
 [<c046c570>] ? kthread_create_on_node+0xc0/0xc0

Potential duplicate: bug 994438
Comment 1 Leon 2013-08-18 11:59:57 EDT
Created attachment 787793 [details]
File: dmesg
Comment 2 Petr Praus 2013-08-21 11:05:36 EDT
Description of problem:
I resumed computer from sleep (RAM) and a kernel oops occured. Dmesg contains the following:

[22194.858491] PM: Syncing filesystems ... done.
[22196.622762] PM: Preparing system for mem sleep
[22197.703735] Freezing user space processes ... (elapsed 0.12 seconds) done.
[22197.825236] Freezing remaining freezable tasks ... (elapsed 0.01 seconds) done.
[22197.836150] PM: Entering mem sleep
[22197.836203] Suspending console(s) (use no_console_suspend to debug)
[22197.837739] sd 0:0:0:0: [sda] Synchronizing SCSI cache
[22197.838095] sd 0:0:0:0: [sda] Stopping disk
[22197.855194] p3p1: Going into suspend...
[22197.855289] ------------[ cut here ]------------
[22197.855305] WARNING: at drivers/pci/pci.c:1393 pci_disable_device+0x85/0x90()
[22197.855311] Device e100
disabling already-disabled device
[22197.855468] Modules linked in: rndis_host cdc_ether usbnet fuse ipt_MASQUERADE nf_conntrack_netbios_ns nf_conntrack_broadcast ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i cxgb3 mdio libcxgbi ib_iser rdma_cm ib_addr iw_cm ib_cm ib_sa ib_mad ib_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi snd_intel8x0 snd_intel8x0m snd_ac97_codec ac97_bus snd_seq iTCO_wdt iTCO_vendor_support acpi_cpufreq snd_seq_device snd_pcm mperf snd_page_alloc snd_timer snd ipw2200 soundcore microcode libipw cfg80211 joydev i2c_i801 of_i2c lpc_ich sony_laptop lib80211 rfkill uinput i915
[22197.855490]  i2c_algo_bit drm_kms_helper yenta_socket e100 drm mii firewire_ohci firewire_core crc_itu_t i2c_core video usb_storage sunrpc
[22197.855499] CPU: 0 PID: 3101 Comm: kworker/u2:7 Not tainted 3.10.7-100.fc18.i686 #1
[22197.855503] Hardware name: Sony Corporation PCG-TR3A(UC), BIOS R0111G1 11/28/2003
[22197.855513] Workqueue: events_unbound async_run_entry_fn
[22197.855528]  dc007dd4 dc007dd4 dc007d9c c097fbda dc007dc4 c043ea74 c0b60988 dc007df0
[22197.855541]  00000571 c06a4b45 c06a4b45 df12b800 df12b800 dc007e23 dc007ddc c043eb33
[22197.855553]  00000009 dc007dd4 c0b60988 dc007df0 dc007df8 c06a4b45 c0b41c4e 00000571
[22197.855556] Call Trace:
[22197.855569]  [<c097fbda>] dump_stack+0x16/0x18
[22197.855581]  [<c043ea74>] warn_slowpath_common+0x64/0x80
[22197.855588]  [<c06a4b45>] ? pci_disable_device+0x85/0x90
[22197.855595]  [<c06a4b45>] ? pci_disable_device+0x85/0x90
[22197.855603]  [<c043eb33>] warn_slowpath_fmt+0x33/0x40
[22197.855610]  [<c06a4b45>] pci_disable_device+0x85/0x90
[22197.855638]  [<e04ff476>] __e100_shutdown+0x86/0x120 [e100]
[22197.855647]  [<c06a6c90>] ? pci_pm_poweroff+0xd0/0xd0
[22197.855666]  [<e04ff586>] e100_suspend+0x16/0x50 [e100]
[22197.855674]  [<c06a6555>] pci_legacy_suspend+0x35/0xc0
[22197.855681]  [<c06a6c90>] ? pci_pm_poweroff+0xd0/0xd0
[22197.855688]  [<c06a6d6c>] pci_pm_suspend+0xdc/0x140
[22197.855697]  [<c075f415>] ? __pm_runtime_barrier+0x15/0x100
[22197.855708]  [<c096d8b1>] ? klist_next+0x21/0xe0
[22197.855715]  [<c06a6c90>] ? pci_pm_poweroff+0xd0/0xd0
[22197.855725]  [<c075c82b>] dpm_run_callback+0x3b/0x90
[22197.855734]  [<c075ef04>] ? pm_wakeup_pending+0xc4/0x140
[22197.855743]  [<c075c942>] __device_suspend+0xc2/0x200
[22197.855751]  [<c075d17f>] async_suspend+0x1f/0x90
[22197.855758]  [<c046564b>] async_run_entry_fn+0x3b/0x150
[22197.855770]  [<c046da1f>] ? wake_up_process+0x1f/0x40
[22197.855780]  [<c04589c9>] process_one_work+0x119/0x370
[22197.855788]  [<c04599c5>] ? manage_workers.isra.24+0x1b5/0x270
[22197.855796]  [<c0459b76>] worker_thread+0xf6/0x310
[22197.855804]  [<c0459a80>] ? manage_workers.isra.24+0x270/0x270
[22197.855811]  [<c045edf4>] kthread+0x94/0xa0
[22197.855824]  [<c098c437>] ret_from_kernel_thread+0x1b/0x28
[22197.855831]  [<c045ed60>] ? kthread_create_on_node+0xc0/0xc0
[22197.855836] ---[ end trace e94388db490fd37f ]---
[22197.856181] e100 0000:02:08.0: System wakeup enabled by ACPI
[22197.867103] ipw2200 0000:02:0b.0: power state changed by ACPI to D3cold
[22198.423773] ata_piix 0000:00:1f.1: can't derive routing for PCI INT A
[22198.423810] PM: suspend of devices complete after 587.215 msecs
[22198.424172] PM: late suspend of devices complete after 0.353 msecs
[22198.424543] ehci-pci 0000:00:1d.7: System wakeup enabled by ACPI
[22198.435175] uhci_hcd 0000:00:1d.2: System wakeup enabled by ACPI
[22198.435264] uhci_hcd 0000:00:1d.1: System wakeup enabled by ACPI
[22198.435351] uhci_hcd 0000:00:1d.0: System wakeup enabled by ACPI
[22198.435453] PM: noirq suspend of devices complete after 11.274 msecs
[22198.435777] ACPI: Preparing to enter system sleep state S3
[22198.442168] PM: Saving platform NVS memory
[22198.442377] Disabling non-boot CPUs ...
[22198.442377] ACPI: Low-level resume complete
[22198.442377] PM: Restoring platform NVS memory
[22198.442377] microcode: CPU0 sig=0x695, pf=0x20, revision=0x7
[22198.442377] ACPI: Waking up from system sleep state S3
[22198.569235] uhci_hcd 0000:00:1d.0: System wakeup disabled by ACPI
[22198.569327] uhci_hcd 0000:00:1d.1: System wakeup disabled by ACPI
[22198.569415] uhci_hcd 0000:00:1d.2: System wakeup disabled by ACPI
[22198.580129] ehci-pci 0000:00:1d.7: System wakeup disabled by ACPI
[22198.591121] yenta_cardbus 0000:02:05.0: power state changed by ACPI to D0
[22198.613158] ipw2200 0000:02:0b.0: power state changed by ACPI to D0
[22198.613493] PM: noirq resume of devices complete after 55.350 msecs
[22198.613770] PM: early resume of devices complete after 0.200 msecs
[22198.614232] i915 0000:00:02.0: setting latency timer to 64
[22198.641360] uhci_hcd 0000:00:1d.0: setting latency timer to 64
[22198.641389] usb usb2: root hub lost power or was reset
[22198.641641] uhci_hcd 0000:00:1d.1: setting latency timer to 64
[22198.641665] usb usb3: root hub lost power or was reset
[22198.641911] uhci_hcd 0000:00:1d.2: setting latency timer to 64
[22198.641935] usb usb4: root hub lost power or was reset
[22198.642080] pci 0000:00:1e.0: setting latency timer to 64
[22198.642323] ata_piix 0000:00:1f.1: can't derive routing for PCI INT A
[22198.642329] ata_piix 0000:00:1f.1: setting latency timer to 64
[22198.642633] snd_intel8x0 0000:00:1f.5: setting latency timer to 64
[22198.642789] snd_intel8x0m 0000:00:1f.6: setting latency timer to 64
[22198.642855] ehci-pci 0000:00:1d.7: setting latency timer to 64
[22198.642890] e100 0000:02:08.0: System wakeup disabled by ACPI
[22198.642899] p3p1: Coming out of suspend...
[22198.817266] ata2.01: NODEV after polling detection
[22198.820677] ata2.00: ACPI cmd ef/03:0c:00:00:00:a0 (SET FEATURES) filtered out
[22198.820685] ata2.00: ACPI cmd ef/03:42:00:00:00:a0 (SET FEATURES) filtered out
[22198.826498] ata2.00: configured for UDMA/33
[22199.085059] usb 3-1: reset full-speed USB device number 2 using uhci_hcd
[22199.274111] firewire_core 0000:02:05.1: rediscovered device fw0
[22200.607353] ata1.00: ACPI cmd ef/03:0c:00:00:00:a0 (SET FEATURES) filtered out
[22200.607362] ata1.00: ACPI cmd ef/03:45:00:00:00:a0 (SET FEATURES) filtered out
[22200.610422] ata1.00: configured for UDMA/100
[22200.613821] sd 0:0:0:0: [sda] Starting disk
[22200.754922] PM: resume of devices complete after 2141.141 msecs
[22200.755633] PM: Finishing wakeup.
[22200.755638] Restarting tasks ... done.
[22200.792283] video LNXVIDEO:00: Restoring backlight state
[22203.448006] IPv6: ADDRCONF(NETDEV_UP): em1: link is not ready
[22203.454125] IPv6: ADDRCONF(NETDEV_UP): p3p1: link is not ready
[22203.675337] IPv6: ADDRCONF(NETDEV_UP): p3p1: link is not ready
[22207.487183] IPv6: ADDRCONF(NETDEV_CHANGE): p3p1: link becomes ready

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.5
cmdline:        BOOT_IMAGE=/vmlinuz-3.10.7-100.fc18.i686 root=UUID=35b4904a-bccf-4c2b-ac1a-753b787897ea ro rd.md=0 rd.lvm=0 rd.dm=0 rd.luks=0 vconsole.keymap=us rhgb quiet LANG=en_US.UTF-8
kernel:         3.10.7-100.fc18.i686
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: at drivers/pci/pci.c:1393 pci_disable_device+0x85/0x90()
Device e100
disabling already-disabled device
Modules linked in: rndis_host cdc_ether usbnet fuse ipt_MASQUERADE nf_conntrack_netbios_ns nf_conntrack_broadcast ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i cxgb3 mdio libcxgbi ib_iser rdma_cm ib_addr iw_cm ib_cm ib_sa ib_mad ib_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi snd_intel8x0 snd_intel8x0m snd_ac97_codec ac97_bus snd_seq iTCO_wdt iTCO_vendor_support acpi_cpufreq snd_seq_device snd_pcm mperf snd_page_alloc snd_timer snd ipw2200 soundcore microcode libipw cfg80211 joydev i2c_i801 of_i2c lpc_ich sony_laptop lib80211 rfkill uinput i915 i2c_algo_bit drm_kms_helper yenta_socket e100 drm mii firewire_ohci firewire_core crc_itu_t i2c_core video usb_storage sunrpc
CPU: 0 PID: 3101 Comm: kworker/u2:7 Not tainted 3.10.7-100.fc18.i686 #1
Hardware name: Sony Corporation PCG-TR3A(UC), BIOS R0111G1 11/28/2003
Workqueue: events_unbound async_run_entry_fn
 dc007dd4 dc007dd4 dc007d9c c097fbda dc007dc4 c043ea74 c0b60988 dc007df0
 00000571 c06a4b45 c06a4b45 df12b800 df12b800 dc007e23 dc007ddc c043eb33
 00000009 dc007dd4 c0b60988 dc007df0 dc007df8 c06a4b45 c0b41c4e 00000571
Call Trace:
 [<c097fbda>] dump_stack+0x16/0x18
 [<c043ea74>] warn_slowpath_common+0x64/0x80
 [<c06a4b45>] ? pci_disable_device+0x85/0x90
 [<c06a4b45>] ? pci_disable_device+0x85/0x90
 [<c043eb33>] warn_slowpath_fmt+0x33/0x40
 [<c06a4b45>] pci_disable_device+0x85/0x90
 [<e04ff476>] __e100_shutdown+0x86/0x120 [e100]
 [<c06a6c90>] ? pci_pm_poweroff+0xd0/0xd0
 [<e04ff586>] e100_suspend+0x16/0x50 [e100]
 [<c06a6555>] pci_legacy_suspend+0x35/0xc0
 [<c06a6c90>] ? pci_pm_poweroff+0xd0/0xd0
 [<c06a6d6c>] pci_pm_suspend+0xdc/0x140
 [<c075f415>] ? __pm_runtime_barrier+0x15/0x100
 [<c096d8b1>] ? klist_next+0x21/0xe0
 [<c06a6c90>] ? pci_pm_poweroff+0xd0/0xd0
 [<c075c82b>] dpm_run_callback+0x3b/0x90
 [<c075ef04>] ? pm_wakeup_pending+0xc4/0x140
 [<c075c942>] __device_suspend+0xc2/0x200
 [<c075d17f>] async_suspend+0x1f/0x90
 [<c046564b>] async_run_entry_fn+0x3b/0x150
 [<c046da1f>] ? wake_up_process+0x1f/0x40
 [<c04589c9>] process_one_work+0x119/0x370
 [<c04599c5>] ? manage_workers.isra.24+0x1b5/0x270
 [<c0459b76>] worker_thread+0xf6/0x310
 [<c0459a80>] ? manage_workers.isra.24+0x270/0x270
 [<c045edf4>] kthread+0x94/0xa0
 [<c098c437>] ret_from_kernel_thread+0x1b/0x28
 [<c045ed60>] ? kthread_create_on_node+0xc0/0xc0
Comment 3 Josh Boyer 2013-09-20 14:53:54 EDT

*** This bug has been marked as a duplicate of bug 968058 ***

Note You need to log in before you can comment on or make changes to this bug.