Bug 998266 - Strange provides in junit rpm package: mvn(junit:junit) = @version@
Strange provides in junit rpm package: mvn(junit:junit) = @version@
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: junit (Show other bugs)
19
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Stanislav Ochotnicky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-18 14:16 EDT by Mattias Ellert
Modified: 2013-08-29 03:53 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 03:53:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mattias Ellert 2013-08-18 14:16:55 EDT
Description of problem:

$ rpm -q --provides junit
junit = 0:4.11-1.fc19
junit4 = 0:4.11-1.fc19
mvn(junit:junit) = @version@
osgi(org.junit) = 4.10.0

The @version@ string looks like it was supposed to have been replaced during the build.

Version-Release number of selected component (if applicable):

junit-4.11-1.fc19.noarch
Comment 1 Stanislav Ochotnicky 2013-08-19 04:22:57 EDT
This was intermittent issue in our toolset. Latest builds actually don't suffer from this. I am going to send latest build through updates-testing. Thanks for reporting
Comment 2 Fedora Update System 2013-08-19 06:17:39 EDT
junit-4.11-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/junit-4.11-5.fc19
Comment 3 Fedora Update System 2013-08-27 19:29:11 EDT
junit-4.11-6.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.