Bug 998286 - Github repository upstream cloning gives a problem with Neutron submodule
Github repository upstream cloning gives a problem with Neutron submodule
Status: CLOSED NOTABUG
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
unspecified
All All
unspecified Severity urgent
: ---
: ---
Assigned To: Ivan Chavero
Ami Jeain
: OtherQA
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-18 18:37 EDT by Ivan Chavero
Modified: 2015-06-04 17:53 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.3.dev722.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-09 04:23:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 42571 None None None Never
OpenStack gerrit 42839 None None None Never

  None (edit)
Description Ivan Chavero 2013-08-18 18:37:49 EDT
Description of problem:

While cloning the packstack upstream repository from github i get an error fetching the neutron submodule:

Clone of 'https://github.com/stackforge/puppet-quantum.git' into submodule path 'packstack/puppet/modules/neutron' failed

Checking the .gitsubmodule file i found that the neutron submodule references to https://github.com/stackforge/puppet-quantum.git which does not exist in github.

[submodule "packstack/puppet/modules/neutron"]
        path = packstack/puppet/modules/neutron
        url = https://github.com/stackforge/puppet-quantum.git

This issue is a problem for all the branches because the above mentioned repository does not exist, for example on grizzly:

[submodule "packstack/puppet/modules/quantum"]
        path = packstack/puppet/modules/quantum
        url = https://github.com/stackforge/puppet-quantum.git



How reproducible:

always


Steps to Reproduce:
1. git clone --recursive git@github.com:stackforge/packstack.git packstack
2.
3.

Actual results:

fatal: https://github.com/stackforge/puppet-quantum.git/info/refs?service=git-upload-pack not found: did you run git update-server-info on the server?
Clone of 'https://github.com/stackforge/puppet-quantum.git' into submodule path 'packstack/puppet/modules/neutron' failed


Expected results:

Succesfull clone of the repository with all its submodules without errors

Additional info:

This problem is derived from the quantum name change to neutron.

One solution to this bug is edit the .gitmodules file and set the proper repository to the neutron entry:

diff --git a/.gitmodules b/.gitmodules
index 2d12af8..97a4f57 100644
--- a/.gitmodules
+++ b/.gitmodules
@@ -72,4 +72,4 @@
        url = https://github.com/puppetlabs/puppetlabs-vcsrepo.git
 [submodule "packstack/puppet/modules/neutron"]
        path = packstack/puppet/modules/neutron
-       url = https://github.com/stackforge/puppet-quantum.git
+       url = https://github.com/stackforge/puppet-neutron.git

and then run: 

git submodule sync
and
git submodule update
to fetch the module
Comment 1 Martin Magr 2013-08-19 04:13:30 EDT
It looks like puppet-quantum has been deleted from stackforge recently, so your proposal is right.
Comment 2 Martin Magr 2013-08-19 09:46:48 EDT
The bigger problem I see here is grizzly, since we are pointing to puppet-quantum there. We will have to point to packstack fork in grizzly branch also.
Comment 3 Terry Wilson 2013-08-19 10:24:41 EDT
This is odd. I don't know what they did upstream to break it, but according to https://help.github.com/articles/renaming-a-repository it should have handled automatically redirecting from the old name.

We shouldn't have to switch anything but where the submodule points. It should be perfectly ok to have the submodule in grizzly point https://github.com/stackforge/puppet-neutron.git to packstack/puppet/modules/quantum.
Comment 4 Martin Magr 2013-08-20 04:41:29 EDT
Ah, I read your comment Terry after submitting the review. OK will switch to puppet-neutron, so we don't have to have Packstack fork.

Note You need to log in before you can comment on or make changes to this bug.