Bug 998288 - Custom partitions for new installation not seen as usable by installer [NEEDINFO]
Custom partitions for new installation not seen as usable by installer
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-18 18:45 EDT by reescf
Modified: 2013-11-19 13:08 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-19 13:08:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
stephent98: needinfo? (reescf)


Attachments (Terms of Use)

  None (edit)
Description reescf 2013-08-18 18:45:25 EDT
Description of problem:

Using the KDE spin for 64 bit Fedora 19 installation, I opted to use custom partitioning. I tried various formulations but the initial screen persisted on showing partitioning as a blocker. Eventually, I figured out some of what it wanted and cleared the block. (Those errors I'll report separately.)

However, when I continued installation, I was told insufficient space was available for Fedora. Even though I had e.g. assigned a 15G partition to / in the "New ... Installation", it would claim that I had only e.g. 997M of space available for Fedora. In the end, the only option I had was to "reclaim space", delete the partitions I'd created for Fedora and let it do the partitioning itself. It did not do this as I would have preferred. (That's understandable - it has to be a one-size-fits-all - but that's why a custom option is critical.)

Version-Release number of selected component (if applicable):

Fedora-Live-KDE-x86_64-19-1.iso

How reproducible:

I tried custom partitioning several times, setting things up differently each time. For example, I thought maybe it didn't like my use of a customised volume group name, so I tried with the default name fedora. And it seemed to want a BIOS boot partition (even though it had a perfectly good EFI partition and previously booted Fedora 17 in EFI mode). But nothing worked. Whatever I assigned in the custom partition set up it just saw as "used" space and marked unavailable to the new installation.

In fact, the only space it saw in an "existing" partition which it said could be "reclaimed" was on the /home partition which was the one I was trying to preserve in the first place.

Steps to Reproduce:
1. Use the KDE spin.
2. Set up custom partitioning
3. Try to install.

Actual results:

Partitioned space is "unavailable" so installation is blocked.

Expected results:

Installer sees space I've assigned to the new installation as available to put the new install on.

Additional info:

GPT partition map
Partitions in Fedora 17 were: /, /var, /home, /boot, /boot/efi
Partition I wanted to use as was in Fedora 19: /home
Partitions I wanted to remove: /, /var, /boot, /boot/efi
Partitions I wanted to create: /boot, /boot/efi, LVM for / (I also tried putting /boot in the LVM, not having a separate /boot, leaving space space in the LVM not assigned to /)
Partitions I tried adding to make installer happier: swap, BIOS boot partition

Note that I found one bug which involved this issue but it was mixed in with a bunch of unrelated ones and closed as a rant. I think that action was understandable but I think the issue is one which is real and should be addressed. I therefore opened a (hopefully) non-ranting bug.

Please note that I did read the help provided on partitioning but it did not tell me how to persuade the installer to recognise custom partitions assigned to the new install as usable space.

Also, the disk in question was checked in the disk selection screen and the dialogue to set it as a boot device also showed it as checked.
Comment 1 Steve Tyler 2013-08-20 06:50:24 EDT
Could you attach the installer log files from /tmp after using Manual Partitioning to configure storage? Quit the installer from Installation Summary once you have confirmed that the installer is rejecting the storage configuration and then look for files named /tmp/*log:

Please attach as separate, uncompressed, text/plain files.

Note You need to log in before you can comment on or make changes to this bug.