Bug 998302 - Browse page fails for non-enterable products
Browse page fails for non-enterable products
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
4.4
Unspecified Unspecified
low Severity low (vote)
: ---
: ---
Assigned To: Simon Green
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-18 22:06 EDT by Jason McDonald
Modified: 2014-10-12 18:51 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.4.0009
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-03 20:46:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason McDonald 2013-08-18 22:06:22 EDT
Description of problem:
When you select a non-retired product on the Browse page (e.g. https://bugzilla.redhat.com/page.cgi?id=browse.html&tab=&product=Bugzilla&bug_status=open), correct data is shown. 

Howeverm when you select any of the Retired products, other than "test" (e.g. https://bugzilla.redhat.com/page.cgi?id=browse.html&tab=summary&product=Red+Hat+Linux&product_version=&bug_status=open), you are just shown the initial browse page with the first item in the drop-down list selected and no bug data displayed.

Version-Release number of selected component (if applicable):
4.4.0006

How reproducible:
always

Steps to Reproduce:
1. Go to https://bugzilla.redhat.com/
2. Click Browse link near top of page
3. Select "Red Hat Linux" from the first drop-down list, then click "Submit".

Actual results:
Initial Browse page is presented again

Expected results:
Bug summary for Red Hat Linux should be displayed.

Additional info:
If I use the Search page to search for CLOSED bugs in the Red Hat Linux product, I get more than 1000 results.
Comment 1 Simon Green 2013-08-28 20:54:00 EDT
So it turns out if you could see a product, but couldn't enter a bug in it (either because the product is non enterable, or you don't have the correct group permission), you couldn't get the details.

I've changed the code so that it will display if you can enter or view bugs in the product.

  -- simon
Comment 2 Simon Green 2013-10-03 20:46:11 EDT
This change is now live. If there are any issues, do not reopen this bug.
Instead, you should create a new bug and reference this bug.

  -- simon

Note You need to log in before you can comment on or make changes to this bug.