Bug 998321 - cracklib-python brroken
cracklib-python brroken
Status: CLOSED DUPLICATE of bug 972542
Product: Fedora
Classification: Fedora
Component: cracklib (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-18 23:36 EDT by Amit Saha
Modified: 2015-07-26 18:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-20 02:37:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amit Saha 2013-08-18 23:36:20 EDT
Description of problem:

The tests fail:

ERROR: test_cracklib:TestModuleFunctions.test_VeryFascistCheck
  vi +20  /usr/lib/python2.7/site-packages/test_cracklib.py  # test_VeryFascistCheck
    cracklib.VeryFascistCheck('test', dictpath=dictpath)
  vi +209 /usr/lib/python2.7/site-packages/cracklib.py  # VeryFascistCheck
    FascistCheck(new)
OSError: [Errno 2] No such file or directory: '/usr/share/cracklib/pw_dict.pwd'

ERROR: test_cracklib:TestModuleFunctions.test_palindrome
  vi +31  /usr/lib/python2.7/site-packages/test_cracklib.py  # test_palindrome
    cracklib.VeryFascistCheck('ot23#xyx#32to', dictpath=dictpath)
  vi +209 /usr/lib/python2.7/site-packages/cracklib.py  # VeryFascistCheck
    FascistCheck(new)
OSError: [Errno 2] No such file or directory: '/usr/share/cracklib/pw_dict.pwd'

ERROR: test_cracklib:TestModuleFunctions.test_simple
  vi +63  /usr/lib/python2.7/site-packages/test_cracklib.py  # test_simple
    cracklib.VeryFascistCheck('t3sx24', dictpath=dictpath)
  vi +209 /usr/lib/python2.7/site-packages/cracklib.py  # VeryFascistCheck
    FascistCheck(new)
OSError: [Errno 2] No such file or directory: '/usr/share/cracklib/pw_dict.pwd'

11 tests, 0 failures, 3 errors in 0.0s


Version-Release number of selected component (if applicable):

cracklib-python-2.9.0-2.fc20.x86_64

How reproducible:

Always


Steps to Reproduce:
1. Run the tests in test_cracklib.py
2.
3.

Actual results:


Expected results:

All tests pass


Additional info:
Comment 1 Tomas Mraz 2013-08-19 08:29:04 EDT
Do you have cracklib-dicts package installed?
Comment 2 Nalin Dahyabhai 2013-08-19 14:12:58 EDT
This looks like a duplicate of #972542.
Comment 3 Amit Saha 2013-08-19 20:10:06 EDT
(In reply to Tomas Mraz from comment #1)
> Do you have cracklib-dicts package installed?

Yes, cracklib-dicts-2.9.0-2.fc20.x86_64.
Comment 4 Amit Saha 2013-08-19 20:11:07 EDT
(In reply to Nalin Dahyabhai from comment #2)
> This looks like a duplicate of #972542.

Yeah, i think that's it. I see the .gz file.
Comment 5 Tomas Mraz 2013-08-20 02:37:30 EDT

*** This bug has been marked as a duplicate of bug 972542 ***

Note You need to log in before you can comment on or make changes to this bug.