Bug 998343 - Hibernate soft lock warning on removing a user from a language team
Hibernate soft lock warning on removing a user from a language team
Status: CLOSED UPSTREAM
Product: Zanata
Classification: Community
Component: Component-Logic (Show other bugs)
3.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Sean Flanigan
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 01:21 EDT by Damian Jansen
Modified: 2015-07-30 21:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-30 21:49:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damian Jansen 2013-08-19 01:21:36 EDT
Description of problem:
On removing a language member the message
"A soft-locked cache entry was expired by the underlying Ehcache."
is shown in the console.

Version-Release number of selected component (if applicable):
3.0

How reproducible:
Easy always

Steps to Reproduce:
1. Sign in as admin
2. Click Languages
3. Choose a language with >0 members
4. Press Remove on any user

Actual results:
Warning on console.

Expected results:
No warnings.

Additional info:
15:17:03,614 WARN  [org.hibernate.cache.ehcache.internal.strategy.AbstractReadWriteEhcacheAccessStrategy] (http-/127.0.0.1:8080-1) HHH020008: Cache[org.zanata.model.HLocale.members] Key[org.zanata.model.HLocale.members#1] Lockable[(null)]
A soft-locked cache entry was expired by the underlying Ehcache. If this happens regularly you should consider increasing the cache timeouts and/or capacity limits
Comment 1 Sean Flanigan 2013-08-19 02:38:02 EDT
This might be the cause: https://hibernate.atlassian.net/browse/HHH-7250
Comment 2 Damian Jansen 2013-08-19 19:37:37 EDT
The HHH-7250 was fixed (apparently) - maybe it's no-so-fixed or there's another manifestation of the problem somewhere.
Comment 3 Ding-Yi Chen 2014-03-17 20:16:55 EDT
Bug confirmed with:
INFO  [org.hibernate.Version] (ServerService Thread Pool -- 55) HHH000412: Hibernate Core {4.2.7.SP1-redhat-3}
Comment 4 Damian Jansen 2014-07-28 01:42:50 EDT
Tested 3.5.0-SNAPSHOT (git-server-3.4.2-201-ge0afdde) - still an issue
Comment 5 Zanata Migrator 2015-07-30 21:49:57 EDT
Migrated; check JIRA for bug status: http://zanata.atlassian.net/browse/ZNTA-565

Note You need to log in before you can comment on or make changes to this bug.