Bug 998352 - [RHEV-RHS] vms goes into paused state after starting rebalance
[RHEV-RHS] vms goes into paused state after starting rebalance
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: fuse (Show other bugs)
mainline
All Linux
high Severity high
: ---
: ---
Assigned To: Raghavendra Bhat
: TestBlocker
: 990397 (view as bug list)
Depends On: 960046
Blocks: 922183 922361 923774 990397
  Show dependency treegraph
 
Reported: 2013-08-19 01:53 EDT by Raghavendra Bhat
Modified: 2014-07-11 14:18 EDT (History)
12 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 960046
Environment:
virt rhev integration
Last Closed: 2014-04-17 07:46:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-08-19 01:59:29 EDT
REVIEW: http://review.gluster.org/5601 (mount/fuse: save the basefd flags in the new fd) posted (#2) for review on master by Raghavendra Bhat (raghavendra@redhat.com)
Comment 2 Anand Avati 2013-08-19 21:19:11 EDT
COMMIT: http://review.gluster.org/5601 committed in master by Anand Avati (avati@redhat.com) 
------
commit 41fa8da33435b8ba05a7eddbccddd96cde1aa762
Author: Raghavendra Bhat <raghavendra@redhat.com>
Date:   Tue Aug 13 19:47:01 2013 +0530

    mount/fuse: save the basefd flags in the new fd
    
    Upon graph switch, the basefd's flags were not saved in the new fd created
    for the new graph upon which all the further requests for the open file
    would come. Thus posix was treating the fd as a read-only fd and was
    denying the write on the fds.
    
    Change-Id: I781b62b376a85d1a938c091559270c3f242f1a2a
    BUG: 998352
    Signed-off-by: Raghavendra Bhat <raghavendra@redhat.com>
    Reviewed-on: http://review.gluster.org/5601
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 3 Anand Avati 2013-09-09 20:54:39 EDT
REVIEW: http://review.gluster.org/5880 (mount/fuse: save the basefd flags in the new fd) posted (#1) for review on release-3.4 by Anand Avati (avati@redhat.com)
Comment 4 Anand Avati 2013-09-09 21:10:04 EDT
REVIEW: http://review.gluster.org/5880 (mount/fuse: save the basefd flags in the new fd) posted (#2) for review on release-3.4 by Anand Avati (avati@redhat.com)
Comment 5 Anand Avati 2013-09-10 04:23:19 EDT
COMMIT: http://review.gluster.org/5880 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit 873ac7b37b0b6c18a14969286ebcf89bb67dfee2
Author: Raghavendra Bhat <raghavendra@redhat.com>
Date:   Tue Aug 13 19:47:01 2013 +0530

    mount/fuse: save the basefd flags in the new fd
    
    Upon graph switch, the basefd's flags were not saved in the new fd created
    for the new graph upon which all the further requests for the open file
    would come. Thus posix was treating the fd as a read-only fd and was
    denying the write on the fds.
    
    Change-Id: I781b62b376a85d1a938c091559270c3f242f1a2a
    BUG: 998352
    Signed-off-by: Raghavendra Bhat <raghavendra@redhat.com>
    Reviewed-on: http://review.gluster.org/5880
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 6 Niels de Vos 2014-04-17 07:46:05 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 7 Niels de Vos 2014-07-11 14:18:47 EDT
*** Bug 990397 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.