Bug 998405 - Win7 x86 guest BSOD(0x000000F4) when create partition
Win7 x86 guest BSOD(0x000000F4) when create partition
Status: CLOSED DUPLICATE of bug 987221
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 04:40 EDT by xu
Modified: 2013-08-21 00:58 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-21 00:58:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
WinDbg dump result (15.46 KB, text/plain)
2013-08-19 04:40 EDT, xu
no flags Details
BSOD screenshot (15.31 KB, image/png)
2013-08-19 04:41 EDT, xu
no flags Details

  None (edit)
Description xu 2013-08-19 04:40:55 EDT
Created attachment 787951 [details]
WinDbg dump result

Description of problem:

create partition on a virtio_blk disk always failed, diskpart report operation timeout, "rescan" maybe helpful to solve this issue, so add rescan before create partition primary line, run again then guest BSOD and qemu report error:

qemu: virtio_ioport_write: unexpected address 0x13 value 0x1


Version-Release number of selected component (if applicable):

qemu-kvm-1.5.2-3.el7.x86_64
virtio-win-prewhql-0.1-65

How reproducible:

always fail at diskpart, but BSOD only one times

Steps to Reproduce:
1. boot win7 32bit guest with cmdline:

/root/autotest-devel/client/tests/virt/qemu/qemu \
    -name 'virt-tests-vm1' \
    -nodefaults \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20130819-125530-OLbrbUmB,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control \
    -chardev socket,id=serial_id_serial1,path=/tmp/serial-serial1-20130819-125530-OLbrbUmB,server,nowait \
    -device isa-serial,chardev=serial_id_serial1 \
    -chardev socket,id=seabioslog_id_20130819-125530-OLbrbUmB,path=/tmp/seabios-20130819-125530-OLbrbUmB,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20130819-125530-OLbrbUmB,iobase=0x402 \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=0x4 \
    -drive file='/root/autotest-devel/client/tests/virt/shared/data/images/win7-32-virtio.qcow2',index=0,if=none,id=drive-virtio-disk1,media=disk,cache=unsafe,snapshot=off,format=qcow2,aio=native \
    -device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk1,bootindex=0 \
    -drive file='/root/autotest-devel/client/tests/virt/shared/data/images/storage.qcow2',index=2,if=none,id=drive-virtio-disk2,media=disk,cache=unsafe,snapshot=off,format=qcow2,aio=native \
    -device virtio-blk-pci,bus=pci.0,addr=0x6,drive=drive-virtio-disk2,bootindex=1 \
    -device virtio-net-pci,netdev=idVbWVQX,mac='9a:f8:f9:fa:fb:fc',bus=pci.0,addr=0x3,id='idWV0PQz' \
    -netdev tap,id=idVbWVQX,vhost=on \
    -m 4096 \
    -smp 2,maxcpus=2,cores=1,threads=1,sockets=2 \
    -cpu 'SandyBridge',,hv_relaxed \
    -M pc \
    -drive file='/root/win.iso',index=1,if=none,id=drive-ide0-0-0,media=cdrom,format=raw \
    -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 \
    -vnc :0 \
    -vga std \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off  \
    -enable-kvm \
    -monitor stdio


2. go into windows "disk managerment" window, then select second disk to create "simple volume";

3. wait for report failed

4. used diskpart cmd create partition again:
    
diskpart /s cmd

content of cmd:
select disk 1
clean all
rescan
create partition primary
assign letter=I
exit


Actual results:

guest BSOD

Expected results:

new partition created 

Additional info:

see windbg dump result in attachment
Comment 1 xu 2013-08-19 04:41:58 EDT
Created attachment 787952 [details]
BSOD screenshot

BSOD screen-shot
Comment 4 Mike Cao 2013-08-20 08:36:05 EDT
xu,pls upload dump file to this bug instead of only paste !analyze -v
Comment 7 Mike Cao 2013-08-21 00:58:48 EDT

*** This bug has been marked as a duplicate of bug 987221 ***

Note You need to log in before you can comment on or make changes to this bug.