Bug 998479 - Updated user information in OpenLDAP are not propagated to engine
Updated user information in OpenLDAP are not propagated to engine
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Ravi Nori
Ondra Machacek
infra
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 08:11 EDT by Ondra Machacek
Modified: 2016-02-10 14:20 EST (History)
11 users (show)

See Also:
Fixed In Version: is15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-29 03:35:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18886 None None None Never

  None (edit)
Description Ondra Machacek 2013-08-19 08:11:07 EDT
Description of problem:
When user's informations are updated in OpenLDAP then these informations
are not propagated to engine in internal(3600s). After ~12hours it is still not
propagated.

Version-Release number of selected component (if applicable):
is10

How reproducible:
always

Steps to Reproduce:
1. Have OpenLDAP with some user.
2. update users' information. (ie, email, or add/remove group to user)
3. Wait 3600s and check if informations are propageted to engine.

Actual results:
Informations are not propageted to rhevm.

Expected results:
Informations are propageted.

Additional info:
Comment 1 Ravi Nori 2013-09-09 15:54:25 EDT
I have posted a fix for OpenLdap as I was only able to reproduce this for OpenLdap, worked fine for Ad, 389DS and FreeIPA.

Please let me know if the issue was seen only for OpenLdap or other ldap servers too.
Comment 2 Shai Revivo 2013-09-29 03:35:01 EDT
This bug was fixed and is slated to be in the upcoming version. As we are focusing our testing at this phase on severe bugs, this bug was closed without going through its verification step

Note You need to log in before you can comment on or make changes to this bug.