Bug 998499 - baseurl metadata downloads broken after 734cf28
baseurl metadata downloads broken after 734cf28
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: librepo (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mlcoch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 09:00 EDT by Ales Kozumplik
Modified: 2014-09-30 19:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-03 04:43:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Kozumplik 2013-08-19 09:00:41 EDT
It seems that commit 734cf28 breaks the following:

#! /usr/bin/python

import librepo
import time

MIRROR="""https://mirrors.fedoraproject.org/metalink?repo=updates-released-f19&arch=x86_64"""
DESTDIR="./"
URL="""http://linuxdownload.adobe.com/linux/x86_64/"""


if __name__ == "__main__":
    h = librepo.Handle()
    h.destdir = DESTDIR
    h.interruptible = True
    h.repotype = librepo.LR_YUMREPO
    h.url = URL
    h.yumdlist = ["primary", "filelists", "prestodelta", "group_gz"]
    # h.local = True
    h.perform(librepo.Result())
    print(h.url)
    print(h.mirrors)

the error is:
librepo.LibrepoException: (19, 'Yum repo downloading error: Downloading error(s): repodata/filelists.xml.gz - Cannot download, all mirrors were already tried without success; repodata/primary.xml.gz - Cannot download, all mirrors were already tried without success', 'Usable URL not found')

Please treat prior to releasing the new librepo version.
Comment 1 Tomas Mlcoch 2013-08-20 04:29:29 EDT
Fixed in HEAD https://github.com/Tojaj/librepo/commit/eef00afa5cc9c7890670c8271d7b890b97550979

The issue was caused by the fact, that "sha" checksum in context of repodata means "sha1" checksum.
Comment 2 Ales Kozumplik 2013-08-20 04:57:58 EDT
This works, thanks.

Note You need to log in before you can comment on or make changes to this bug.