This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 998502 - Transitive Trusts with Active Directory support for FreeIPA
Transitive Trusts with Active Directory support for FreeIPA
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Changes Tracking (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Reznik
: Tracking
Depends On:
Blocks: 1008209 1008210
  Show dependency treegraph
 
Reported: 2013-08-19 09:03 EDT by Jaroslav Reznik
Modified: 2013-12-18 09:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1008209 1008210 (view as bug list)
Environment:
Last Closed: 2013-12-18 09:00:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2013-08-19 09:03:54 EDT
This is a tracking bug for Change: Transitive Trusts with Active Directory support for FreeIPA
For more details, see: http://fedoraproject.org//wiki/Changes/IPAv3TransitiveTrusts

FreeIPA will support transitive trusts with Active Directory
Comment 1 Alexander Bokovoy 2013-08-26 23:20:18 EDT
I'm on vacation and will only be able to work fully on the feature starting September.
Comment 2 Jaroslav Reznik 2013-09-17 07:34:09 EDT
Alexander, 
what's the current state of this Change?
Comment 3 Alexander Bokovoy 2013-09-17 07:45:16 EDT
Couple bugs identified and being fixed on FreeIPA and SSSD sides. Patches for FreeIPA side are on review on the upstream mailing list.

We are scoping out Global Catalog parts (i.e. log-in as IPA user to Active Directory machines) due to time shortage before F20 release. Transitive trusts for complex AD forests accessing IPA resources will be supported.
Comment 4 Jaroslav Reznik 2013-10-11 04:42:14 EDT
This message is a reminder that Fedora 20 Accepted Changes 100%
Completed Deadline is on 2013-10-15 [1].

All Accepted Changes has to be code complete and ready to be
validated in the Beta release (optionally by Fedora QA). Required
bug state at this point is ON_QA.

As for several System Wide Changes, Beta Change Deadline is a
point of contingency plan, all incomplete Changes will be 
reported to FESCo for 2013-10-16 meeting. In case of any
questions, don't hesitate to ask Wrangler (jreznik).

[1] https://fedoraproject.org/wiki/Releases/20/Schedule
Comment 5 Alexander Bokovoy 2013-10-11 04:57:08 EDT
Since FreeIPA 3.3.2 was released last week and is now available in Fedora 20, moving the bug to ON_QA status.

As stated in the comment 3, feature was reduced to "Access to FreeIPA resources from multi-domain Active Directory forests".
Comment 6 Jaroslav Reznik 2013-12-18 09:00:29 EST
Closing this bug as this Change was delivered in Fedora 20 release. Please, reopen in case of any issues you encounter regarding this Change completion.

Note You need to log in before you can comment on or make changes to this bug.