This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 998538 - Camel quickstarts parent pom.xml lists many camel modules (quickstarts) that are not shipped with SOA6 - result is that the quickstarts that are shipped cannot be run from parent pom.xml
Camel quickstarts parent pom.xml lists many camel modules (quickstarts) that ...
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Build Process (Show other bugs)
6.0.0 GA
Unspecified Unspecified
high Severity urgent
: ER4
: ---
Assigned To: Julian Coleman
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 09:37 EDT by Robert Balent
Modified: 2015-08-02 19:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Balent 2013-08-19 09:37:43 EDT
Description of problem:

There are new 2 camel quickstarts in JBoss SOA-P 6. They contains parent pom.xml which contains in modules section all camel examples.

When you try to build two examples from parent pom it will crash with error.

There should be only 2 examples mentioned in parent pom.xml


Steps to reproduce:

1. cd boss-eap-6.1/quickstarts/camel/
2. mvn clean install
3. Error
Comment 1 Len DiMaggio 2013-09-10 08:47:27 EDT
Marking as beta blocker - the quickstarts should work OOTB.
Comment 2 Anne-Louise Tangring 2013-09-10 10:06:29 EDT
Do the individual examples build? Is this a problem only on the top level build?
Comment 3 Len DiMaggio 2013-09-11 12:37:42 EDT
This problem exists if the examples are run from their parent directory.

The examples can be run individually from their own sub-directories.
Comment 4 Len DiMaggio 2013-09-23 08:27:26 EDT
Can the parent pom.xml simply be removed from the build?
Comment 5 Len DiMaggio 2013-09-23 08:29:45 EDT
The parent pom references these quickstarts:

 <modules>
    <module>camel-example-aggregate</module>
    <module>camel-example-bam</module>
    <module>camel-example-cafe</module>
    <module>camel-example-cxf</module>
    <module>camel-example-cxf-blueprint</module>
    <module>camel-example-cxfrs-http</module>
    <module>camel-example-cxf-osgi</module>
    <module>camel-example-cxf-proxy</module>
    <module>camel-example-cxf-tomcat</module>
    <module>camel-example-console</module>
    <module>camel-example-docs</module>
    <module>camel-example-etl</module>
    <module>camel-example-gae</module>
    <module>camel-example-gauth</module>
    <module>camel-example-guice-jms</module>
    <module>camel-example-jmx</module>
    <module>camel-example-jms-file</module>
    <module>camel-example-loadbalancing</module>
    <module>camel-example-loan-broker</module>
    <module>camel-example-management</module>
    <module>camel-example-osgi</module>
    <module>camel-example-osgi-rmi</module>
    <module>camel-example-pojo-messaging</module>
    <module>camel-example-reportincident</module>
    <module>camel-example-reportincident-wssecurity</module>
    <module>camel-example-riderautoparts</module>
    <module>camel-example-route-throttling</module>
    <module>camel-example-servlet-tomcat</module>
    <module>camel-example-simplejirabot</module>
    <module>camel-example-spring</module>
    <module>camel-example-spring-javaconfig</module>
    <module>camel-example-spring-jms</module>
    <module>camel-example-spring-ws</module>
    <module>camel-example-spring-xquery</module>
    <module>camel-example-spring-security</module>
    <module>camel-example-ssh</module>
    <module>camel-example-tracer</module>
    <module>camel-example-twitter-websocket</module>
  </modules>


But - only these are shipped with SOA6:

camel-example-cxf-tomcat
camel-example-servlet-tomcat
Comment 6 Robert Balent 2013-09-23 08:43:16 EDT
Parent pom.xml references to maven repositories which contains artifacts needed for building quickstarts.
Comment 7 Julian Coleman 2013-09-23 16:13:07 EDT
Resolved with commit 1583bf6fcf469adf212f27ed60c706fe55edd2f5 of ip.git:

  BZ-998538
  Remove camel examples parent POM, as this is confusing because it refers
  to examples that we don't ship.
Comment 9 Robert Balent 2013-10-07 03:40:23 EDT
Now when the parent pom.xml is removed, quickstarts can't be built just as they are. Now customer need to have offline repository configured. Is it intended behaviour?
Comment 12 Robert Balent 2013-10-22 11:31:59 EDT
Examples can be correctly built with configured maven repository as described in settings.xml example for Beta version. Marking as verified.

Note You need to log in before you can comment on or make changes to this bug.