Bug 998563 - Migrate to Bluez 5
Migrate to Bluez 5
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Changes Tracking (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Reznik
: Tracking
Depends On:
Blocks: 1001338 1001339
  Show dependency treegraph
 
Reported: 2013-08-19 10:16 EDT by Jaroslav Reznik
Modified: 2014-01-07 06:28 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1001338 1001339 (view as bug list)
Environment:
Last Closed: 2013-12-18 09:01:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2013-08-19 10:16:23 EDT
This is a tracking bug for Change: Migrate to Bluez 5
For more details, see: http://fedoraproject.org//wiki/Changes/Bluez5

BlueZ is the Linux Bluetooth stack for managing wireless Bluetooth devices. In Fedora 20, we are going to switch from BlueZ version 4 to version 5.
Comment 1 Jaroslav Reznik 2013-10-11 04:46:30 EDT
This message is a reminder that Fedora 20 Accepted Changes 100%
Completed Deadline is on 2013-10-15 [1].

All Accepted Changes has to be code complete and ready to be
validated in the Beta release (optionally by Fedora QA). Required
bug state at this point is ON_QA.

As for several System Wide Changes, Beta Change Deadline is a
point of contingency plan, all incomplete Changes will be 
reported to FESCo for 2013-10-16 meeting. In case of any
questions, don't hesitate to ask Wrangler (jreznik).

[1] https://fedoraproject.org/wiki/Releases/20/Schedule
Comment 2 Pavel Šimerda (pavlix) 2013-10-17 03:40:49 EDT
I'm very curious whether stuff like bluetooth PAN and bluetooth DUN will be still working or whether there will be regression in functionality.
Comment 3 Kalev Lember 2013-10-17 04:46:57 EDT
Pavel, see https://bugzilla.gnome.org/show_bug.cgi?id=701078#c49 and later comments for what's exactly implemented in NetworkManager.
Comment 4 Jaroslav Reznik 2013-12-18 09:01:23 EST
Closing this bug as this Change was delivered in Fedora 20 release. Please, reopen in case of any issues you encounter regarding this Change completion.
Comment 5 Carl van Tonder 2014-01-06 10:35:03 EST
This change removes support for bluetooth audio devices in "headset" (HSP) profile.

I can find no discussion of this regression in mailing list or IRC archives, in #1001338 or this bug, or on the Bluez5 feature page. I am curious as to how this task was completed without anyone mentioning this known limitation -- a QA group meeting in July raised the fact that the status of that feature was unknown, but nothing seems to have been said since then.

It's probably way too late now, but the feature page had a "Contingency plan" for "major bluetooth-related regressions" -- whose decision was it to declare that there were no "major .. regressions"?
Comment 6 Jaroslav Reznik 2014-01-07 06:28:25 EST
It's the decision of Change owner unless concerns are raised (in time) to FESCo.

Note You need to log in before you can comment on or make changes to this bug.