Bug 998572 - SELinux is preventing /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25-2.3.12.3.fc19.x86_64/jre/bin/java from 'create' accesses on the directory .icedtea.
SELinux is preventing /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25-2.3.12.3.fc19....
Status: CLOSED DUPLICATE of bug 967298
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:a7b603a25bd1a68b1b0e7b75b6b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 10:24 EDT by Devon Janitz
Modified: 2013-08-20 05:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-20 05:01:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Devon Janitz 2013-08-19 10:24:38 EDT
Description of problem:
Opened the website logmein.com.
SELinux is preventing /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25-2.3.12.3.fc19.x86_64/jre/bin/java from 'create' accesses on the directory .icedtea.

*****  Plugin mozplugger (99.1 confidence) suggests  *************************

If you want to use the plugin package
Then you must turn off SELinux controls on the Firefox plugins.
Do
# setsebool unconfined_mozilla_plugin_transition 0

*****  Plugin catchall (1.81 confidence) suggests  ***************************

If you believe that java should be allowed create access on the .icedtea directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep java /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
                              0.c1023
Target Context                unconfined_u:object_r:user_home_dir_t:s0
Target Objects                .icedtea [ dir ]
Source                        java
Source Path                   /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25-2.3.12.3.
                              fc19.x86_64/jre/bin/java
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           java-1.7.0-openjdk-1.7.0.25-2.3.12.3.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-69.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.10.7-200.fc19.x86_64 #1 SMP Thu
                              Aug 15 23:19:45 UTC 2013 x86_64 x86_64
Alert Count                   31
First Seen                    2013-08-19 10:13:19 EDT
Last Seen                     2013-08-19 10:17:15 EDT
Local ID                      cf3bd02d-3126-40a0-9e43-1972cd53fea9

Raw Audit Messages
type=AVC msg=audit(1376921835.566:707): avc:  denied  { create } for  pid=7729 comm="java" name=".icedtea" scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=dir


type=SYSCALL msg=audit(1376921835.566:707): arch=x86_64 syscall=mkdir success=no exit=EACCES a0=7fb7c8000c10 a1=1ff a2=7fb8976b82c0 a3=7fb8976cb740 items=0 ppid=6810 pid=7729 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=1 tty=(none) comm=java exe=/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25-2.3.12.3.fc19.x86_64/jre/bin/java subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)

Hash: java,mozilla_plugin_t,user_home_dir_t,dir,create

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.7-200.fc19.x86_64
type:           libreport

Potential duplicate: bug 967298
Comment 1 Miroslav Grepl 2013-08-20 05:01:47 EDT

*** This bug has been marked as a duplicate of bug 967298 ***

Note You need to log in before you can comment on or make changes to this bug.