Bug 998580 - Issues in the ABRT API documentation.
Issues in the ABRT API documentation.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
560
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Matej Kollar
:
Depends On:
Blocks: sat560-abrt
  Show dependency treegraph
 
Reported: 2013-08-19 10:26 EDT by Dimitar Yordanov
Modified: 2013-10-01 17:26 EDT (History)
3 users (show)

See Also:
Fixed In Version: spacewalk-java-2.0.2-23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:26:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimitar Yordanov 2013-08-19 10:26:48 EDT
Description of problem:
There are issues in the API documentation for ABRT caused by syntax error in Java Doc. 

Version-Release number of selected component (if applicable):
spacewalk-java-1.9.83-46

How reproducible:
Always

Steps to Reproduce:
1. Help -> API -> Overview -> system.crash
https://xxxxx.redhat.com/rhn/apidoc/handlers/CrashHandler.jsp
2.  API call getCrashOverview
https://xxxxx.redhat.com/rhn/apidoc/handlers/CrashHandler.jsp#getCrashOverview

   or API call getCrashesByUuid

https://xxxx.redhat.com/rhn/apidoc/handlers/CrashHandler.jsp#getCrashesByUuid

Actual results: 
  API documentation is broken -> #prop_des

 Method: getCrashOverview
Description:
Get Software Crash Overview

Parameters:

    string sessionKey

Returns:

    array:
        struct - crash
            string "uuid" - Crash UUID
            string "component" - Package component (set if unique and non empty)
            int "crash_count" - Number of crashes occurred
            #prop_des("int", "system_count", "Number of systems affected")
            dateTime.iso8601 "last_report" - Last crash occurence

Method: getCrashesByUuid
Description:
List software crashes with given UUID

Parameters:

    string sessionKey
    string uuid

Returns:

    array:
        struct - crash
            int "server_id" - ID of the server the crash occurred on
            #prop_des("string", "server_name", "Name of the server the crash occured on")
            int "crash_id" - ID of the crash with given UUID
            int "crash_count" - Number of times the crash with given UUID occurred
            string "crash_component" - Crash component
            dateTime.iso8601 "last_report" - Last crash occurence



Expected results:
API documentation is correct. No '#prop_des' strings. 
Additional info:
Comment 1 Dimitar Yordanov 2013-08-19 10:28:36 EDT
Fixed in Spacewalk master: aff95b6fa6ab2699f4940e9153df8e6694d4e580
Comment 6 Clifford Perry 2013-10-01 17:26:53 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.