Bug 998581 - Setting custom font for GTK(3) applications is not respected
Setting custom font for GTK(3) applications is not respected
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kde-settings (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Jan Grulich
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 10:27 EDT by Vitezslav Humpa
Modified: 2017-08-08 07:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-08 07:37:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vitezslav Humpa 2013-08-19 10:27:28 EDT
Description of problem:
Setting custom font for GTK+ applications through Application Appearance module of SystemSettings gets ignored. No matter the font/size etc. I set, apps still  use the KDE font. Exception is that in case of GTK2 apps, the font is respected with secondary dialogs/preferences etc., but never inside the main window's interface. With GTK3 apps, font gets ignored in all places.

Version-Release number of selected component (if applicable):
KDE 4.10.4

Steps to Reproduce:
1. Start systemsettings, go to 'Application Appearance' module
2. Go to GTK+ Appearance page
3. Change the font under 'Use another font', apply

Actual results:
As described before

Expected results:
Font gets used for all GTK2/3 applications, including the main window UI's font

Additional info:
I've indeed tried restarting the apps as well as re-logging the whole session.
Comment 1 Daniel Vrátil 2013-10-01 12:52:45 EDT
Can you please confirm that file .gtkrc-2.0-kde4 exists and contains something like this?

style "user-font"
{
        font_name="Font You Have Selected"
}
widget_class "*" style "user-font"

gtk-theme-name="oxygen-gtk"
gtk-font-name="Font And Size You Have Selected"
Comment 2 Daniel Vrátil 2014-02-11 09:32:17 EST
The tool shipped in RHEL7 only support changing settings of GTK2 applications.

I tried with Wireshark (a GTK2 app) and it seems to work for me with current up-to-date RHEL7.

kcm-gtk-0.5.3-14.el7
gtk2-2.24.22-5.el7
Comment 3 RHEL Product and Program Management 2014-03-22 02:41:32 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Jan Grulich 2017-08-08 07:37:19 EDT
Given we dropped oxygen-gtk3 in RHEL this won't never be fixed.

Note You need to log in before you can comment on or make changes to this bug.