Bug 998721 - org.eclipse.jdt.feature.group seems to depend on old hamcrest
org.eclipse.jdt.feature.group seems to depend on old hamcrest
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 17:25 EDT by Gerard Ryan
Modified: 2013-08-22 14:00 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-22 14:00:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerard Ryan 2013-08-19 17:25:27 EDT
Description of problem:
While trying to build eclipse-m2e-core in a local rawhide mock environment, I'm running into this:

[ERROR] Cannot resolve project dependencies:
[ERROR]   Software being installed: org.eclipse.m2e.feature.feature.group 1.4.0.qualifier
[ERROR]   Missing requirement: org.eclipse.jdt.feature.group 3.9.0.v20130802-1542 requires 'org.hamcrest.core [1.1.0.v20090501071000]' but it could not be found
[ERROR]   Cannot satisfy dependency: org.eclipse.m2e.feature.feature.group 1.4.0.qualifier depends on: org.eclipse.jdt.feature.group 3.6.0
[ERROR] 


Version-Release number of selected component (if applicable):
eclipse-jdt-1:4.3.0-10.fc20.x86_64
hamcrest-0:1.3-5.fc20.noarch
Comment 1 Alexander Kurtakov 2013-08-20 03:14:12 EDT
Would you please try with eclipse-4.3.0-11.fc20 ? The usual problem is that p2 metadata has way stronger enforcement than actual osgi. So we need to rebuild to get it regenerated.
Comment 2 Gerard Ryan 2013-08-22 14:00:46 EDT
That seems to have fixed it, thanks Alexander! :)

Note You need to log in before you can comment on or make changes to this bug.