Bug 998786 - quota: list shows no information
quota: list shows no information
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Raghavendra G
Saurabh
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 01:14 EDT by Saurabh
Modified: 2016-01-19 01:12 EST (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.36rhs-1
Doc Type: Bug Fix
Doc Text:
Previously, the trusted.glusterfs.quota.size extended attribute was not created on the / mount due to which the extended attribute which holds the size was not created and hence the wrong size was display on the CLI. Now, with this fix the correct size is displayed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 10:31:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-08-20 01:14:36 EDT
Description of problem:

I executed list after setting the limit of 100GB.
that does not show the numbers as intended.

Version-Release number of selected component (if applicable):
glusterfs-server-3.4.0.20rhsquota1-1.el6.x86_64
glusterfs-fuse-3.4.0.20rhsquota1-1.el6.x86_64
glusterfs-3.4.0.20rhsquota1-1.el6.x86_64

How reproducible:
happening on this build

Steps to Reproduce:
1. create a 6x2 volume, start it
2. enable quota
3. set limit on the root of the volume

Actual results:
[root@rhsauto032 ~]# gluster volume quota dist-rep list /
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
[root@rhsauto032 ~]# 


Expected results:

the Path should show the path of dir, here it should be "/"
the Hard limit should show "100GB" as per this case
the Soft-limit should show " the percentage.
Used should show the "the amount the space not occupied"
Available should show "the amount of space occupied"


Additional info:
Comment 2 Krutika Dhananjay 2013-08-21 01:28:54 EDT
This works for me. The next time you hit this issue, could you provide the xattrs (and perhaps the logs as well)?
Comment 4 Krutika Dhananjay 2013-08-21 05:06:32 EDT
Root Cause for the case described in Comment #3 is the following:

The xattr 'trusted.glusterfs.quota.size' is missing in the backend. Therrefore,  getxattr on 'trusted.glusterfs.quota.size' fails from the cli (which essentially means that cli does not have the consumed space for displaying in the output of list). Hence the cli displays "N/A" in the 'Used' and 'Available' columns because it truly doesn't have the necessary information available for displaying.
Comment 5 Raghavendra G 2013-08-21 05:25:26 EDT
Its a minor regression introduced by http://review.gluster.org/#/c/5615/. Because of this patch no size xattr is set on / till some data is populated. This issue is seen only when brick directory is empty. Still trying to root-cause the issue.
Comment 6 Krutika Dhananjay 2013-09-02 02:46:02 EDT
The bug is not in cli and exists because of the absence of trusted.glusterfs.quota.size attribute on the root of the volume after limit is set on it. Hence re-assigning it to Raghavendra G.
Comment 7 Raghavendra G 2013-10-23 07:43:14 EDT
https://code.engineering.redhat.com/gerrit/#/c/14140/ is the patch which fixes the issue.
Comment 9 errata-xmlrpc 2013-11-27 10:31:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.