Bug 998801 - RFE: Add XMPP-local-messaging service entry
RFE: Add XMPP-local-messaging service entry
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 02:06 EDT by Ankur Sinha (FranciscoD)
Modified: 2014-06-19 18:58 EDT (History)
2 users (show)

See Also:
Fixed In Version: firewalld-0.3.10-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-19 18:58:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
avahi-bonjour firewalld xml file (233 bytes, text/xml)
2013-08-20 02:06 EDT, Ankur Sinha (FranciscoD)
no flags Details
service for XMPP Link-Local Messaging (264 bytes, application/xml)
2013-09-17 04:16 EDT, Jiri Popelka
no flags Details

  None (edit)
Description Ankur Sinha (FranciscoD) 2013-08-20 02:06:54 EDT
Created attachment 788320 [details]
avahi-bonjour firewalld xml file

Description of problem:
Could you please add a service entry for avahi? It's used by the empathy "people near me" feature and should be readily available to end users. 


Version-Release number of selected component (if applicable):
firewalld-0.3.4-1.fc19.noarch


Based on this post: http://saravananthirumuruganathan.wordpress.com/2010/04/04/empathy-chat-messenger-tutorial/

the ports that need to be added are: tcp 5298,udp 5353. I've made a minimal file that should be enough. I'll ask the avahi-maintainers to look it over though.

Thanks,
Warm regards,
Ankur
Comment 1 Ankur Sinha (FranciscoD) 2013-08-20 02:18:57 EDT
5353 seems to be open as "mdns". I'm not certain of 5298 though.
Comment 2 Jiri Popelka 2013-08-20 04:35:19 EDT
(In reply to Ankur Sinha (FranciscoD) from comment #1)
> 5353 seems to be open as "mdns".

Correct. mDNS port has been opened by default since Fedora 18 due to
http://fedoraproject.org/wiki/Features/AvahiDefaultOnDesktop
The configuration file is
https://git.fedorahosted.org/cgit/firewalld.git/plain/config/services/mdns.xml

> I'm not certain of 5298 though.

Neither do I.

# grep 5298 /etc/services 
presence        5298/tcp                # XMPP Link-Local Messaging
Comment 3 Jiri Popelka 2013-09-17 04:16:16 EDT
Created attachment 798661 [details]
service for XMPP Link-Local Messaging

What about this one ?
Comment 5 Fedora Update System 2014-05-29 05:08:17 EDT
firewalld-0.3.10-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/firewalld-0.3.10-1.fc20
Comment 6 Fedora Update System 2014-05-29 19:23:02 EDT
Package firewalld-0.3.10-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing firewalld-0.3.10-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-6834/firewalld-0.3.10-1.fc20
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2014-06-19 18:58:09 EDT
firewalld-0.3.10-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.