Bug 998833 - session-migration: attempt to complete a workitem fails on strategy not found.
session-migration: attempt to complete a workitem fails on strategy not found.
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Core (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER3
: 6.0.0
Assigned To: Kris Verlaenen
Marek Baluch
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 03:57 EDT by Marek Baluch
Modified: 2014-08-06 16:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:10:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stack (26.04 KB, text/plain)
2013-08-20 03:58 EDT, Marek Baluch
no flags Details

  None (edit)
Description Marek Baluch 2013-08-20 03:57:16 EDT
Description of problem:

An attempt made to complete a workitem created in jbpm5 fails with "No strategy of type org.drools.marshalling.impl.SerializablePlaceholderResolverStrategy available."

The issue is probably caused by refactoring. Looks like the class exists in package org.drools.core.marshalling.impl.
Comment 1 Marek Baluch 2013-08-20 03:58:19 EDT
Created attachment 788351 [details]
stack
Comment 2 Marek Baluch 2013-08-20 03:59:31 EDT
The tested process is BPMN2-UserTask.bpmn2 available in the jbpm repository. It's not using the DoNothingWorkItemHandler.
Comment 3 Marek Baluch 2013-08-20 04:00:25 EDT
I meant to write "it IS using the DoNothingWorkItemHandler".
Comment 4 Kris Verlaenen 2013-08-22 19:57:14 EDT
http://github.com/droolsjbpm/drools/commit/95583e5de
Comment 5 Marek Baluch 2013-09-19 09:16:40 EDT
Verified on ER3.

Note You need to log in before you can comment on or make changes to this bug.