Bug 998841 - Permanent fix of HHH-8447 (HQL delete with multiple subqueries failing (incorrect alias used))
Permanent fix of HHH-8447 (HQL delete with multiple subqueries failing (incor...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Hibernate (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ER1
: EAP 6.2.0
Assigned To: Brett Meyer
Zbyněk Roubalík
Russell Dickenson
:
Depends On:
Blocks: eap62-upgrade-hibernate425
  Show dependency treegraph
 
Reported: 2013-08-20 03:59 EDT by Adam Kovari
Modified: 2015-09-01 00:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
If a HQL delete query contained multiple subqueries, only the first subquery would use the correct root table alias. The generated SQL for the other subqueries would use an incorrect alias. This issue was caused by improper processing of multiple subqueries when generating the SQL query. This issue has been fixed in this release of JBoss EAP 6 so that HQL delete queries with multiple subqueries will now use the correct root table alias when generating SQL for all subqueries.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:21:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Kovari 2013-08-20 03:59:56 EDT
Description of problem:
https://hibernate.atlassian.net/browse/HHH-8447

Version-Release number of selected component (if applicable):
EAP 6.1.0
Comment 1 Zbyněk Roubalík 2013-09-23 07:32:06 EDT
EAP 6.2.0.ER1

Note You need to log in before you can comment on or make changes to this bug.