Bug 998862 - db-control reset-password doesn't work on EmbPostgreSQL
db-control reset-password doesn't work on EmbPostgreSQL
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
560
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Dobes
Martin Minar
:
Depends On:
Blocks: 553004
  Show dependency treegraph
 
Reported: 2013-08-20 05:08 EDT by Jan Dobes
Modified: 2016-07-03 20:58 EDT (History)
2 users (show)

See Also:
Fixed In Version: spacewalk-setup-postgresql-2.0.1-3 spacewalk-web-2.0.3-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:52:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Dobes 2013-08-20 05:08:07 EDT
Description of problem:
When I run 'db-control reset-password' on EmbPostgreSQL, it doesn't change password and ends with error.

Version-Release number of selected component (if applicable):
spacewalk-web-2.0.3-8

How reproducible:
always

Steps to Reproduce:
1. Make your database running.
2. Have some password in /etc/rhn/rhn.conf - db_password
3. run 'db-control reset-password'

Actual results:
RHN::DB connect('dbname=rhnschema','',...) failed: FATAL:  no pg_hba.conf entry for host "[local]", user "root", database "rhnschema", SSL off at /usr/share/perl5/vendor_perl/Dobby/DB.pm line 503
Can't call method "do" on an undefined value at /usr/share/perl5/vendor_perl/Dobby/DB.pm line 507.

Expected results:
Changes password and exits without error.
Comment 2 Jan Dobes 2013-08-20 08:27:20 EDT
fixed in spacewalk master:
336d3821484fee860ec92170550d75cb3b2e8326
5ac583f7bd1f32c83b84c684380dab28493554ee
Comment 6 Clifford Perry 2013-10-01 17:52:52 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.