Bug 998863 - No field to specify a Satellite Server present when creating a filter
No field to specify a Satellite Server present when creating a filter
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: Splice (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Splice Developers
mkovacik
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-08-20 05:11 EDT by mkovacik
Modified: 2013-10-01 07:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:20:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The New Filter menu screenshot showing missing Satellite Server field (80.34 KB, image/png)
2013-08-20 05:11 EDT, mkovacik
no flags Details
The Filter Details Menu showing present Satellite Server field (97.80 KB, image/png)
2013-08-20 05:12 EDT, mkovacik
no flags Details

  None (edit)
Description mkovacik 2013-08-20 05:11:51 EDT
Created attachment 788389 [details]
The New Filter menu screenshot showing missing Satellite Server field

Description of problem:
There is satellite host field present when creating a new filter. Still, having created a filter, one is able to change the Satellite Server field in the filter details menu.  

Version-Release number of selected component (if applicable):
Snapshot #3

How reproducible:
Always

Steps to Reproduce:
1. navigate: Administer -> Reports -> New Filter
2. no Satellite Server field present


Additional info:
See attached screenshots
Comment 1 mkovacik 2013-08-20 05:12:58 EDT
Created attachment 788392 [details]
The Filter Details Menu showing present Satellite Server field
Comment 2 wes hayutin 2013-08-20 14:32:38 EDT
FYI... The design was to only support one satellite server.  
I agree it looks odd to have it listed in the display/edit page w/o in the filter creation page.

The choice was made to remove it from the filter create due to the limited amount of space.  The edit filter page also serves as a page to list the values. The satellite server field was never intended to be edited.

You may consider removing it from the display edit page vs.. the filter create page.
Comment 3 John Matthews 2013-08-21 12:06:44 EDT
Chris and I discussed this and we decided for SAM 1.3. to restore the drop down box for the Satellite Server in the 'new' filter page, as well as allow it to remain in the 'edit' filter page.

https://github.com/splice/splice-reports/commit/bac30b3022a0ae9bf1cdc5eae6abadbb1d8006d3
Comment 4 Bryan Kearney 2013-08-28 13:11:49 EDT
Lates build (Snap4) should contain these fixes. Please test on Snap4.
Comment 5 Vitaly Kuznetsov 2013-09-13 07:00:01 EDT
Verified with Snapshot 6, field for Satellite Server selection is in place.
Comment 7 errata-xmlrpc 2013-10-01 07:20:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.