Bug 998904 - quota: rename fails
quota: rename fails
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Raghavendra Bhat
Saurabh
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 06:23 EDT by Saurabh
Modified: 2016-01-19 01:12 EST (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.33rhs
Doc Type: Bug Fix
Doc Text:
Previously, on a quota enabled volume, renames performed on a directory with quota limits set, may fail due to an accounting logic error. Now with this update, the accounting logic handles rename operations correctly, and the rename operations work as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 10:31:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-08-20 06:23:47 EDT
Description of problem:
trying to rename a file fails.

Version-Release number of selected component (if applicable):
glusterfs-server-3.4.0.20rhsquota1-1.el6.x86_64
glusterfs-fuse-3.4.0.20rhsquota1-1.el6.x86_64
glusterfs-3.4.0.20rhsquota1-1.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. create a 6x2 volume, start it
2. enable quota
3. set limit on the root of the volume
4. mount the volume over nfs
5. touch "filename"
6. mv "filename" ""newname

Actual results:

[root@rhsauto036 nfs-test]# touch a
[root@rhsauto036 nfs-test]# mv a a-rename
mv: cannot move `a' to `a-rename': No such file or directory

from nfs.log

[2013-08-20 07:34:33.013760] W [client-rpc-fops.c:2385:client3_3_rename_cbk] 0-dist-rep2-client-3: remote operation failed: No such file or directory
[2013-08-20 07:34:33.014422] W [client-rpc-fops.c:2385:client3_3_rename_cbk] 0-dist-rep2-client-2: remote operation failed: No such file or directory
[2013-08-20 07:34:33.014472] W [dht-rename.c:517:dht_rename_cbk] 0-dist-rep2-dht: /a: rename on dist-rep2-replicate-1 failed (No such file or directory)
[2013-08-20 07:34:33.020142] W [nfs3.c:3663:nfs3svc_rename_cbk] 0-nfs: a1b73eec: rename /a -> /a-rename => -1 (No such file or directory)
[2013-08-20 07:34:33.021379] W [client-rpc-fops.c:1529:client3_3_inodelk_cbk] 0-dist-rep2-client-3: remote operation failed: No such file or directory
[2013-08-20 07:34:33.021501] W [client-rpc-fops.c:1529:client3_3_inodelk_cbk] 0-dist-rep2-client-2: remote operation failed: No such file or directory
[2013-08-20 07:34:33.022432] W [client-rpc-fops.c:1529:client3_3_inodelk_cbk] 0-dist-rep2-client-2: remote operation failed: No such file or directory
[2013-08-20 07:34:33.023641] W [client-rpc-fops.c:1529:client3_3_inodelk_cbk] 0-dist-rep2-client-3: remote operation failed: No such file or directory
[2013-08-20 07:34:33.024371] I [afr-lk-common.c:1085:afr_lock_blocking] 0-dist-rep2-replicate-1: unable to lock on even one child
[2013-08-20 07:34:33.024463] I [afr-transaction.c:1063:afr_post_blocking_inodelk_cbk] 0-dist-rep2-replicate-1: Blocking inodelks failed.
[2013-08-20 07:34:33.024556] E [dht-linkfile.c:287:dht_linkfile_setattr_cbk] 0-dist-rep2-dht: setattr of uid/gid on /a :<gfid:00000000-0000-0000-0000-000000000000> failed (No such file or directory)

Expected results:
rename should happen, and gfid should not be returned as "zero value" for an existing file.

Additional info:
Comment 3 Raghavendra G 2013-08-23 00:09:05 EDT
Are there sos reports for this? I need brick and quotad logs in particular.

regards,
Raghavendra.
Comment 6 Raghavendra Bhat 2013-09-24 05:35:48 EDT
https://code.engineering.redhat.com/gerrit/12179 in rhs-2.1 branch fixes the issue.
Comment 7 Gowrishankar Rajaiyan 2013-09-24 07:21:27 EDT
"Fixed In Version" please.
Comment 8 shylesh 2013-09-25 11:38:28 EDT
verified on glusterfs-3.4.0.33rhs . Now rename happens successfully
Comment 9 errata-xmlrpc 2013-11-27 10:31:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.