Bug 998913 - standalone.bat still sets -XX:+TieredCompilation JVM option
standalone.bat still sets -XX:+TieredCompilation JVM option
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Scripts and Commands (Show other bugs)
6.1.0
Unspecified Windows
unspecified Severity high
: ER1
: EAP 6.2.0
Assigned To: David M. Lloyd
Petr Kremensky
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 06:45 EDT by Jaikiran Pai
Modified: 2015-10-21 09:00 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
An issue has been resolved in the `standalone.bat` batch file, used on Microsoft Windows Server. The batch file previously contained a JVM option which set tiered compilation: `-XX:+TieredCompilation`. This setting has been removed as it is known to cause performance problems in some circumstances.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:16:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaikiran Pai 2013-08-20 06:45:16 EDT
https://issues.jboss.org/browse/WFLY-1906 fixes an issue in the standalone.bat file to remove the -XX:+TieredCompilation JVM option. This option was removed from standalone.sh long time back since it was considered to be a performance problem https://issues.jboss.org/browse/AS7-4547. It however, stayed around in the standalone.bat as an oversight. Some users have noticed that this is causing problems in real environments https://community.jboss.org/message/833173#833173 when using EAP 6.1.
Comment 5 Aaron Ogburn 2013-08-21 14:46:44 EDT
Per http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=8008938, some JDK releases may even have tiered compilation enabled by default. We don't want a JDK default setting to lead to those performance issues either so setting -XX:-TieredCompilation instead in the .bat and .sh scripts to override any potential JDK level defaults may be the best option.
Comment 7 Petr Kremensky 2013-09-18 02:21:52 EDT
Verified on 6.2.0.ER1
Comment 13 Dimitris Andreadis 2013-10-24 14:27:55 EDT
Assigning jpai@redhat.com EJB issues to david.lloyd@redhat.com. Please re-assign to Cheng or others as needed.
Comment 14 Russell Dickenson 2013-11-20 21:25:55 EST
Release notes text added, to be published in the JBoss EAP 6.2.0 Release Notes document.
Comment 16 Carlo Marchiori 2015-10-21 03:35:34 EDT
I think this problem should be reported to Oracle, because it's a serious bug of their JVM.
Comment 17 Aaron Ogburn 2015-10-21 09:00:41 EDT
(In reply to Carlo Marchiori from comment #16)
> I think this problem should be reported to Oracle, because it's a serious
> bug of their JVM.

Already was. http://bugs.java.com/view_bug.do?bug_id=7159766

Note You need to log in before you can comment on or make changes to this bug.