Bug 998939 - Failed to acquire org.freedesktop.ConsoleKit: An SELinux policy prevents this sender from sending this message
Failed to acquire org.freedesktop.ConsoleKit: An SELinux policy prevents this...
Status: CLOSED DUPLICATE of bug 998935
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 07:39 EDT by fedorauser
Modified: 2013-08-20 07:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-20 07:56:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
relevant lines from /var/log/messages (starting with the point where the user provides the password at lightdm) (8.20 KB, text/plain)
2013-08-20 07:40 EDT, fedorauser
no flags Details

  None (edit)
Description fedorauser 2013-08-20 07:39:12 EDT
Description of problem:
I'm running a freshly installed Fedora 19 with MATE.
After providing the password at the login screen (lightdm), a SELinux log entry is created and a ConsoleKit timeout appears in /var/log/messages.
I suspect that this is the reason for the ~51 seconds delay before the complete desktop appears - more details below.


Version-Release number of selected component (if applicable):
rpm -qa *selinux*
libselinux-2.1.13-15.fc19.x86_64
libselinux-python-2.1.13-15.fc19.x86_64
selinux-policy-targeted-3.12.1-69.fc19.noarch
selinux-policy-3.12.1-69.fc19.noarch
libselinux-utils-2.1.13-15.fc19.x86_64

rpm -qa dbus*
dbus-1.6.12-1.fc19.x86_64
dbus-glib-0.100-5.fc19.x86_64
dbus-python-1.1.1-5.fc19.x86_64
dbus-x11-1.6.12-1.fc19.x86_64
dbus-libs-1.6.12-1.fc19.x86_64


How reproducible:
always (I can reproduce this in a seconds F19/MATE installation running in a VirtualBox)

Steps to Reproduce:
1. Install Fedora 19 and choose MATE as your desktop environment
2. After the installation is complete enter the password at the login screen (lightdm)
3. observe/confirm the ~51 seconds delay before the destop environment appears (taskbars, Applications menu,..)


Actual results:
It takes ~51 seconds till the desktop environment appears after lightdm got the password from the user.
 
Note the following log entry:

console-kit-daemon[1565]: console-kit-daemon[1565]: WARNING: Failed to acquire org.freedesktop.ConsoleKit: An SELinux policy prevents this sender from sending this message to this recipient, 0 matched rules; type="method_call", sender=":1.25" (uid=0 pid=1426 comm="lightdm --session-child 14 19 ") interface="org.freedesktop.ConsoleKit.Manager" member="OpenSessionWithParameters" error name="(unset)" requested_reply="0" destination="org.freedesktop.ConsoleKit" (uid=0 pid=1565 comm="/usr/sbin/console-kit-daemon --no-daemon ")

and:

dbus[768]: [system] Failed to activate service 'org.freedesktop.ConsoleKit': timed out


Expected results:
The desktop environment should appear within a few seconds.



Additional info:

comments for the attached logfile:
@14:12:59: the user did hit enter at the lightdem login screen
@14:13:51: the complete desktop environment appears
Comment 1 fedorauser 2013-08-20 07:40:56 EDT
Created attachment 788455 [details]
relevant lines from /var/log/messages (starting with the point where the user provides the password at lightdm)
Comment 2 Daniel Walsh 2013-08-20 07:56:53 EDT

*** This bug has been marked as a duplicate of bug 998935 ***

Note You need to log in before you can comment on or make changes to this bug.