Bug 998944 - SSM: Removing packages through SSM does not work.
SSM: Removing packages through SSM does not work.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
560
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Lestach
Dimitar Yordanov
:
Depends On:
Blocks: sat560-blockers 1098014
  Show dependency treegraph
 
Reported: 2013-08-20 08:00 EDT by Matej Kollar
Modified: 2014-05-15 01:39 EDT (History)
5 users (show)

See Also:
Fixed In Version: spacewalk-java-2.0.2-26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1098014 (view as bug list)
Environment:
Last Closed: 2013-10-01 17:56:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matej Kollar 2013-08-20 08:00:03 EDT
Description of problem:

  If packages are scheduled to be removed through SSM, it does not happen
  (even though if scheduled directly (without SSM), it works).

Version-Release number of selected component (if applicable):

  spacewalk-java-2.0.2-15.el6sat.noarch

How reproducible: always/deterministic

Steps to Reproduce:
  0. Register machine
  1. Add machine to ssm
  2. Manage -> Remove packages
  3. Schedule remove some package(s) (say zsh)

Actual results:
  After calling rhn_check, nothing happens (no actions are provided to client),
  package is still present.

Expected results:
  Action is provided to client, package is gone.

Additional info:
  Install & Verify work.
Comment 2 Tomas Lestach 2013-08-26 09:02:46 EDT
Taking for investigation ...
Comment 3 Tomas Lestach 2013-08-27 08:19:44 EDT
The regression was caused by 9b323f28. Fixing ...

spacewalk.git: 3cb69e5c1f120c65395acfaefdd76284c9df7a59
Comment 7 Clifford Perry 2013-10-01 17:56:31 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.