Bug 998950 - RHSM does not use repo_ca_cert setting
RHSM does not use repo_ca_cert setting
Status: CLOSED DUPLICATE of bug 997194
Product: Red Hat Satellite 6
Classification: Red Hat
Component: katello-agent (Show other bugs)
6.0.0
All Linux
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Carter Kozak
Katello QA List
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-08-20 08:10 EDT by Rytis Sileika
Modified: 2014-09-14 20:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-20 08:28:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rytis Sileika 2013-08-20 08:10:41 EDT
Description of problem:

/etc/rhsm/rhsm.conf is pointing to correct certificate:

# grep repo_ca_cert /etc/rhsm/rhsm.conf
repo_ca_cert = %(ca_cert_dir)scandlepin-local.pem

But subscription manager config defaults to a default value:

# subscription-manager config | grep repo_ca_cert
   repo_ca_cert = [/etc/rhsm/ca/redhat-uep.pem]

This means that /etc/yum.repo.d/redhat.repo contains invalid certificate:

# grep sslcacert /etc/yum.repos.d/redhat.repo 
sslcacert = /etc/rhsm/ca/redhat-uep.pem
sslcacert = /etc/rhsm/ca/redhat-uep.pem
[...]

Version-Release number of selected component (if applicable):

subscription-manager-1.9.1-1.el6.x86_64

How reproducible:

Every time

Steps to Reproduce:
1. Install Katello 1.3 server
2. Kickstart a machine with RH6.4
3.

Actual results:


Expected results:


Additional info:

Works as expected with subscription-manager-1.1.23.1-1.el6_4.x86_64
Comment 1 Carter Kozak 2013-08-20 08:28:42 EDT

*** This bug has been marked as a duplicate of bug 997194 ***

Note You need to log in before you can comment on or make changes to this bug.