This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 998955 - [origin_ui_66] When user variable name contains non-alphanumeric characters, no warning prompt message output
[origin_ui_66] When user variable name contains non-alphanumeric characters, ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Fabiano Franz
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 08:19 EDT by weiwei jiang
Modified: 2016-10-30 18:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 08:53:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description weiwei jiang 2013-08-20 08:19:28 EDT
Description of problem:
when add variable with its name contains non-alphanumeric characters, it pass without any errors

Version-Release number of selected component (if applicable):
devenv_3678
rhc build from devenv_3677

How reproducible:
always

Steps to Reproduce:
1.Create a app
2.Add a variable via contains non-alphanumeric characters
rhc env set %asdf=adf -a $app_name
rhc env set %2E=asdf -a $app_name
rhc env set @=asdf -a $app_name
rhc env set == -a $app_name
3.Check the variable if it is added 

Actual results:
rhc env set %asdf=adf -a $app_name
Setting environment variable(s) ... 
Unable to complete the requested operation due to: bad URI(is not URI?):
domains/wjiang/applications/appa/environment-variables/%asdf.
Reference ID: 6c112f87f528b9c5abdb34890fb81247
variable is added but can not `rhc env list `

rhc env set %2E=asdf -a $app_name
Setting environment variable(s) ... done
variable is added and can `rhc env list`

rhc env set @=asdf -a $app_name
Setting environment variable(s) ... done
variable is added and can `rhc env list`

rhc env set == -a $app_name
Setting environment variable(s) ... done
variable is not added

Expected results:


Additional info:
Comment 1 Fabiano Franz 2013-08-21 14:03:12 EDT
Pull request: https://github.com/openshift/rhc/pull/444
Comment 2 weiwei jiang 2013-08-21 22:46:47 EDT
Test on devenv_3683, and all display:
Environment variable(s) not provided.
Please provide at least one environment variable using the syntax
VARIABLE=VALUE. VARIABLE can only contain letters, digits and underscore ('_')
and can't begin with a digit.

so verified this, thx
Comment 3 weiwei jiang 2013-08-22 00:27:12 EDT
And rhc version is rhc build from devenv_3683

Note You need to log in before you can comment on or make changes to this bug.