Bug 998961 - PG does not recover after an exception during API
PG does not recover after an exception during API
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
560
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Tomas Lestach
Matej Kollar
:
Depends On: 996924
Blocks: 819032 sat560-blockers
  Show dependency treegraph
 
Reported: 2013-08-20 08:39 EDT by Tomas Lestach
Modified: 2013-10-01 17:50 EDT (History)
6 users (show)

See Also:
Fixed In Version: spacewalk-java-2.0.2-25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 996924
Environment:
Last Closed: 2013-10-01 17:50:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Tomas Lestach 2013-08-21 09:29:27 EDT
My reproducer is:
=======================================================================
#!/usr/bin/python
import xmlrpclib

SATELLITE_URL = "http://***/rpc/api"
SATELLITE_LOGIN = "***"
SATELLITE_PASSWORD = "***"

client = xmlrpclib.Server(SATELLITE_URL, verbose=0)
key = client.auth.login(SATELLITE_LOGIN, SATELLITE_PASSWORD)

print client.activationkey.listActivationKeys(key)
print client.activationkey.setDetails(key, 'test-key', {'description': 3000*'a'})
aks = client.activationkey.listActivationKeys(key)

client.auth.logout(key)
=======================================================================

Right after the script fails, try to reload couple of pages on WebUI. You may get an ISE depending when you get the connection with aborted transaction from the connection manager.


spacewalk.git: 1711c431413affa3a572ce764c4d2a4b1c6dadfe
Comment 8 Clifford Perry 2013-10-01 17:50:11 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.