Bug 998962 - Dist-geo-rep : geo-rep config special-sync-mode takes any value successfully and make status to faulty.
Dist-geo-rep : geo-rep config special-sync-mode takes any value successfully ...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
urgent Severity medium
: ---
: ---
Assigned To: Avra Sengupta
:
Depends On: 996999
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 08:41 EDT by Avra Sengupta
Modified: 2014-04-17 07:46 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 996999
Environment:
Last Closed: 2014-04-17 07:46:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-08-20 08:42:56 EDT
REVIEW: http://review.gluster.org/5666 (glusterd : Blocking invalid values for geo-rep config options.) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 2 Anand Avati 2013-08-20 08:54:58 EDT
REVIEW: http://review.gluster.org/5666 (glusterd : Blocking invalid values for geo-rep config options.) posted (#2) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 3 Anand Avati 2013-09-05 07:21:05 EDT
REVIEW: http://review.gluster.org/5666 (glusterd : Blocking invalid values for geo-rep config options.) posted (#3) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 4 Anand Avati 2013-09-05 07:28:48 EDT
REVIEW: http://review.gluster.org/5666 (glusterd : Blocking invalid values for geo-rep config options) posted (#4) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 5 Anand Avati 2013-09-17 06:46:18 EDT
COMMIT: http://review.gluster.org/5666 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit ac2317aee9013aa0235318f8a4c808b3598d03b9
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Tue Aug 20 18:09:22 2013 +0530

    glusterd : Blocking invalid values for geo-rep config options
    
    Change-Id: Ia9ee44763a9c2798b26d3225bf03a974d7ece21f
    BUG: 998962
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/5666
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 6 Niels de Vos 2014-04-17 07:46:12 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.