This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 999045 - Changing VNIC profile to another one on the running VM fails with Unexpected exception
Changing VNIC profile to another one on the running VM fails with Unexpected ...
Status: CLOSED DUPLICATE of bug 1001001
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
x86_64 Linux
high Severity unspecified
: ---
: ---
Assigned To: lpeer
GenadiC
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 11:21 EDT by GenadiC
Modified: 2016-02-10 14:58 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-27 16:51:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm log (7.70 MB, text/x-log)
2013-08-20 11:21 EDT, GenadiC
no flags Details
engine log (410.03 KB, text/x-log)
2013-08-20 11:22 EDT, GenadiC
no flags Details
supervdsm log (4.03 MB, text/x-log)
2013-08-20 11:23 EDT, GenadiC
no flags Details

  None (edit)
Description GenadiC 2013-08-20 11:21:32 EDT
Created attachment 788545 [details]
vdsm log

Description of problem:
Trying to change VNIC profile to another one fails with unexpected exception
Happened when changing to profile attached to the same or another network

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Create VM with VNIC profile A attached to network red
2. When VM is up update VM to have VNIC profile B attached to network red instead of A
3.

Actual results:


Expected results:
Action fails

Additional info:
After unplugging NIC and plugging it back the problem disappeared
The logs with the problem attached
Comment 1 GenadiC 2013-08-20 11:22:43 EDT
Created attachment 788547 [details]
engine log
Comment 2 GenadiC 2013-08-20 11:23:38 EDT
Created attachment 788548 [details]
supervdsm log
Comment 3 Dan Kenigsberg 2013-08-27 16:51:30 EDT
It looks like a dup of bug 1001001 (which is a binary palindrome, so I'm keeping it open)


Thread-5668::DEBUG::2013-08-20 17:46:34,578::vm::3101::vm.Vm::(setLinkAndNetwork) vmId=`4f8378d3-b896-4947-b604-844f03b0d4e4`::Request failed: <interface type="bridge">
	<address bus="0x00" domain="0x0000" function="0x0" slot="0x04" type="pci"/>
	<mac address="00:1a:4a:16:88:6f"/>
	<model type="virtio"/>
	<source bridge="red"/>
	<filterref filter="vdsm-no-mac-spoofing"/>
	<link state="up"/>
	<boot order="2"/>
</interface>
Traceback (most recent call last):
  File "/usr/share/vdsm/vm.py", line 3096, in setLinkAndNetwork
    libvirt.VIR_DOMAIN_AFFECT_LIVE)
  File "/usr/share/vdsm/vm.py", line 824, in f
    ret = attr(*args, **kwargs)
  File "/usr/lib64/python2.6/site-packages/vdsm/libvirtconnection.py", line 76, in wrapper
    ret = f(*args, **kwargs)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 1742, in updateDeviceFlags
    if ret == -1: raise libvirtError ('virDomainUpdateDeviceFlags() failed', dom=self)
libvirtError: this function is not supported by the connection driver: cannot modify network device boot index setting

*** This bug has been marked as a duplicate of bug 1001001 ***

Note You need to log in before you can comment on or make changes to this bug.