Bug 999051 - wireless-tools-30.pre9 is available
wireless-tools-30.pre9 is available
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wireless-tools (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 11:40 EDT by Upstream Release Monitoring
Modified: 2015-10-27 05:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-27 05:18:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2013-08-20 11:40:14 EDT
Latest upstream release: 30.pre9
Current version/release in Fedora Rawhide: 29-10.1.fc20
URL: http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/Tools.html

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Fedora Admin XMLRPC Client 2015-10-14 10:49:42 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Account closed by the user 2015-10-14 11:30:36 EDT
(In reply to Upstream Release Monitoring from comment #0)

> Latest upstream release: 30.pre9
> Current version/release in Fedora Rawhide: 29-10.1.fc20


30.pre9 was included in Debian stable long time ago. 
Maintainer(Jean Tourrilhes) says: "The latest beta(30.pre9) work well enough,
it's shipped with Debian Squeeze."


The main features of the latest beta is support for non-ASCII ESSIDs
(such as localised ESSID), support for displaying Scanning Capabilities,
slightly bigger scan buffer, fixing minor bug iwconfig parser and minor
enhancement to ifrename : 

  wireless 30 :
  -----------
	(Suggested by Johannes Berg <johannes@sipsolutions.net>)
o Display non-ASCII char in ESSID using escape sequence [iwlib]
o Allow input of non-ASCII char in ESSID using escape sequence [iwlib]
---
o Fix probing to not probe wildcards (left over '%d'->'*') [ifrename]
o Output number of mapping matched (display + exit status) [ifrename]
	(Bug reported by Ben Hutchings)
o Don't load mapping file if using options '-n' + '-i' [ifrename]
---
o When using takeover, redo probing in case eth0 was in use [ifrename]
o Update Hotplug documentation, add uDev bits [HOTPLUG-UDEV.txt]
o Add ESSID bug patches and documentation [ESSID-BUG.txt]
o Make wireless.21.h LGPL as promised a long time ago [wireless.21.h]
---
	(Bug reported by Shaddy Baddah)
o Fix unaligned access on SPARC in the 64->32 bit workaround [iwlib.c]
---
	(From Maxime Charpenne <maxime.charpenne@free.fr>)
o Mise à jour de la traduction en francais des pages manuel [fr/*]
---
o Use wireless.22.h, make it LGPL [iwlib.h/wireless.22.h]
o Show Scanning Capabilities in "iwlist event" [iwlist]
	(Bug reported by Nikita Zhernosenko)
o Fix parsing of retry/power when modifier is used [iwconfig]
	(Bug reported by Alexis Phoenix)
o Remove trailing '/' in INSTALL_* that fooled checkinstall [Makefile]
	(From Dan Williams <dcbw@redhat.com>)
o Scan capabilities in struct iw_range [wireless.h]
	(From Guus Sliepen <guus@debian.org>)
o Install localised man page [Makefile]
---
o Fix #define that broke 32->64 bit workaround [wireless.22.h]
o Workaround kernel bug when getting ESSID [iwlib/iwconfig/iwgetid]
	(From Gerald Pfeifer  <gerald@pfeifer.com>)
o Fix gramar in man page, add about hidden networks [iwlist.8]
---
	(From Reinette Chatre <reinette.chatre@intel.com>)
o Enable scan buffer to grow up to 65535 instead of 32768 [iwlist]
o Return a proper error if scan result exceed buffer max [iwlist]
	(From Jean Tourrilhes)
o Do above two fixes for the simple scan API [iwlib]
	(From Claudio Ferronato <claiudio@libero.it>)
o Spelling and typos in [iwconfig.8]
---
o Create iwlib-private.h to minimise namespace pollution [iwlib]
o More fix to the 64->32bit band-aid for encode [iwlib]
o Update udev rule to remove a warning [19-udev-ifrename.rules]
	(from Ritesh Raj Sarraf <rrs@researchut.com> and Guus Sliepen)
o Propagate error codes out of main for get [iwconfig/iwlist/iwspy]
	(From Guus Sliepen <guus@debian.org>)
o Remove spurious commands from Czech iwconfig manpage.


Debian patches(debian/patches/*) for 30.pre9: http://http.debian.net/debian/pool/main/w/wireless-tools/wireless-tools_30~pre9-8.debian.tar.gz
Comment 3 Lubomir Rintel 2015-10-27 05:18:12 EDT
Thanks for the report. However, I'm not updating it now, since it's a pre-release -- fixing the release monitoring to only consider stable versions instead.

(In reply to Xose Vazquez Perez from comment #2)
> (In reply to Upstream Release Monitoring from comment #0)
> 
> > Latest upstream release: 30.pre9
> > Current version/release in Fedora Rawhide: 29-10.1.fc20
> 
> 
> 30.pre9 was included in Debian stable long time ago. 
> Maintainer(Jean Tourrilhes) says: "The latest beta(30.pre9) work well enough,
> it's shipped with Debian Squeeze."

I'm wondering why not release a stable version then? Are you in touch with upstream; do you know why they didn't do an actual stable release?

> Debian patches(debian/patches/*) for 30.pre9:
> http://http.debian.net/debian/pool/main/w/wireless-tools/wireless-
> tools_30~pre9-8.debian.tar.gz

Seems like they've done quite some patching. I'd really prefer to see a released version rather than cherry-picking the patches.
Comment 4 Account closed by the user 2015-10-27 05:30:55 EDT
(In reply to Lubomir Rintel from comment #3)

> I'm wondering why not release a stable version then? Are you in touch with
> upstream; do you know why they didn't do an actual stable release?

Yes, time ago. Maintainer said:


On 03/07/2011 05:32 PM, Jean Tourrilhes (jt@hpl.hp.com) wrote:

> Xose wrote:
> will it be released in the future ? or the project is stuck ?

 	I'm busy on other stuff. The latest beta work well enough,
        it's shipped with Debian Squeeze.
 	Regards,
 
 	Jean

Note You need to log in before you can comment on or make changes to this bug.