Bug 999053 - [abrt] WARNING: at drivers/net/wireless/iwlwifi/dvm/../iwl-trans.h:691 iwlagn_mac_flush+0x1a3/0x1b0 [iwldvm]()
[abrt] WARNING: at drivers/net/wireless/iwlwifi/dvm/../iwl-trans.h:691 iwlagn...
Status: CLOSED DUPLICATE of bug 896695
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
abrt_hash:e7d4516e31d074440ea3ad61294...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 11:42 EDT by Michael Clarkson
Modified: 2014-07-25 00:15 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-09 10:06:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (81.66 KB, text/plain)
2013-08-20 11:43 EDT, Michael Clarkson
no flags Details

  None (edit)
Description Michael Clarkson 2013-08-20 11:42:54 EDT
Description of problem:
Using 3.10.6-100.fc18.x86_64 with window manager MATE, latest version. Attached error occurred with iwlwifi. Network remained attached and functional and no other effects observed.

Additional info:
reporter:       libreport-2.1.5
WARNING: at drivers/net/wireless/iwlwifi/dvm/../iwl-trans.h:691 iwlagn_mac_flush+0x1a3/0x1b0 [iwldvm]()
iwl_trans_wait_tx_queue_empty bad state = 0
Modules linked in: fuse ebtable_nat xt_CHECKSUM bridge stp llc nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE bnep bluetooth ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables be2iscsi ip6table_filter iscsi_boot_sysfs ip6_tables bnx2i cnic uio cxgb4i cxgb4 cxgb3i cxgb3 mdio libcxgbi ib_iser rdma_cm ib_addr iw_cm ib_cm ib_sa ib_mad ib_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi acpi_cpufreq mperf coretemp snd_hda_codec_hdmi arc4 iwldvm snd_hda_codec_realtek mac80211 uvcvideo snd_hda_intel videobuf2_vmalloc videobuf2_memops videobuf2_core snd_hda_codec snd_hwdep iTCO_wdt mei_me r8169 videodev snd_seq snd_seq_device snd_pcm snd_page_alloc snd_timer snd iTCO_vendor_support mei iwlwifi microcode cfg80211 media soundcore mii lpc_ich mfd_core jmb38x_ms memstick intel_ips i2c_i801 toshiba_acpi sparse_keymap rfkill wmi vhost_net tun macvtap macvlan kvm_intel kvm binfmt_misc uinput i915 crc32c_intel i2c_algo_bit drm_kms_helper sdhci_pci sdhci drm mmc_core i2c_core video
CPU: 2 PID: 6111 Comm: kworker/u16:0 Not tainted 3.10.6-100.fc18.x86_64 #1
Hardware name: TOSHIBA Satellite M645/NBQAA, BIOS 1.70 12/30/10
Workqueue: phy0 ieee80211_iface_work [mac80211]
 0000000000000009 ffff880171bc7a38 ffffffff81656006 ffff880171bc7a78
 ffffffff8105d660 ffff880171bc7a50 ffff88022ec91800 ffff88022ec91848
 ffff88022da84000 ffff88022ec91810 ffff88022c6e9c60 ffff880171bc7ad8
Call Trace:
 [<ffffffff81656006>] dump_stack+0x19/0x1b
 [<ffffffff8105d660>] warn_slowpath_common+0x70/0xa0
 [<ffffffff8105d746>] warn_slowpath_fmt+0x46/0x50
 [<ffffffffa0529813>] iwlagn_mac_flush+0x1a3/0x1b0 [iwldvm]
 [<ffffffffa04801ed>] ieee80211_flush_queues+0xbd/0x140 [mac80211]
 [<ffffffffa0469031>] __ieee80211_recalc_idle+0xb1/0x100 [mac80211]
 [<ffffffffa04694e8>] ieee80211_recalc_idle+0x18/0x30 [mac80211]
 [<ffffffffa04838eb>] ieee80211_free_chanctx+0xcb/0x1d0 [mac80211]
 [<ffffffffa04842bb>] __ieee80211_vif_release_channel+0x15b/0x200 [mac80211]
 [<ffffffffa04849f1>] ieee80211_vif_release_channel+0x51/0x70 [mac80211]
 [<ffffffffa04958f4>] ieee80211_set_disassoc+0x254/0x3b0 [mac80211]
 [<ffffffffa0495c0b>] ieee80211_sta_connection_lost.isra.23+0x3b/0x80 [mac80211]
 [<ffffffffa0497ad2>] ieee80211_sta_work+0x202/0x1000 [mac80211]
 [<ffffffffa04800f9>] ? ieee80211_wake_queues_by_reason+0x89/0xa0 [mac80211]
 [<ffffffffa0480204>] ? ieee80211_flush_queues+0xd4/0x140 [mac80211]
 [<ffffffffa0468e89>] ieee80211_iface_work+0x2c9/0x360 [mac80211]
 [<ffffffff8107b53a>] process_one_work+0x17a/0x400
 [<ffffffff8107c99c>] worker_thread+0x11c/0x370
 [<ffffffff8107c880>] ? manage_workers.isra.21+0x2b0/0x2b0
 [<ffffffff81082aa0>] kthread+0xc0/0xd0
 [<ffffffff81010000>] ? perf_trace_xen_mmu_flush_tlb_others+0xa0/0x110
 [<ffffffff810829e0>] ? kthread_create_on_node+0x120/0x120
 [<ffffffff816645ac>] ret_from_fork+0x7c/0xb0
 [<ffffffff810829e0>] ? kthread_create_on_node+0x120/0x120

Potential duplicate: bug 990536
Comment 1 Michael Clarkson 2013-08-20 11:43:01 EDT
Created attachment 788552 [details]
File: dmesg
Comment 2 Stanislaw Gruszka 2013-10-09 10:06:49 EDT

*** This bug has been marked as a duplicate of bug 896695 ***

Note You need to log in before you can comment on or make changes to this bug.