Bug 999085 - oo-app-state-show calls "get_app_state" on OpenShift::ApplicationContainer
oo-app-state-show calls "get_app_state" on OpenShift::ApplicationContainer
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
1.2.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 13:43 EDT by Brenton Leanhardt
Modified: 2017-03-08 12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The oo-app-state-show command used a deprecated API and caused an error. This issue has been fixed in the current release, and the oo-app-state-show command now uses the new API and works correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-05 09:24:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brenton Leanhardt 2013-08-20 13:43:36 EDT
Description of problem:
It should instead call "container.state.value"

How reproducible:


Steps to Reproduce:
1. Create a gear
2. oo-app-state-show --with-container-uuid $UUID --with-app-uuid $UUID

Actual results:
undefined method `get_app_state' for #<OpenShift::ApplicationContainer:0x000000021f3ec8>
[root@broker ~]# which aoo-app-state-show

Expected results:
The gear state should be shown.
Comment 1 Miciah Dashiel Butler Masters 2013-08-20 13:46:12 EDT
It's been fixed in Origin:   https://github.com/openshift/origin-server/commit/10aaec7a0ab35c2246f1f7e005952fd9a470ca34#L30L99

But I think we can just remove oo-app-state-show.  Is there any reason to keep it?
Comment 2 Miciah Dashiel Butler Masters 2013-08-20 13:46:59 EDT
Wrong link, sorry.  Here's the fix:   https://github.com/openshift/origin-server/commit/d978c3b9e14d864a35d56714813dffedee13d3a4
Comment 5 Gaoyun Pei 2013-08-21 01:31:37 EDT
Verify this on puddle: 1.2/2013-08-20.1

Create an app, and check its state by oo-app-state-show
[root@node ~]# oo-app-state-show --with-app-uuid 5214256d7074f5201a00045d --with-container-uuid 5214256d7074f5201a00045d
started[root@node ~]#

Stop the app, check again 
[root@node ~]# oo-app-state-show --with-app-uuid 5214256d7074f5201a00045d --with-container-uuid 5214256d7074f5201a00045d
stopped[root@node ~]# 

Idle the app
[root@node ~]# oo-app-state-show --with-app-uuid 5214256d7074f5201a00045d --with-container-uuid 5214256d7074f5201a00045d
idle[root@node ~]#
Comment 8 errata-xmlrpc 2013-09-05 09:24:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1211.html

Note You need to log in before you can comment on or make changes to this bug.