Bug 999086 - Showing full hostname at command prompt for bashrc/cshrc
Showing full hostname at command prompt for bashrc/cshrc
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: setup (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 13:45 EDT by Jóhann B. Guðmundsson
Modified: 2013-09-11 15:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-11 15:11:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bashrc - show full hostname at command prompt (936 bytes, patch)
2013-08-20 13:45 EDT, Jóhann B. Guðmundsson
no flags Details | Diff
cshrc - show full hostname at command prompt (936 bytes, patch)
2013-08-20 13:46 EDT, Jóhann B. Guðmundsson
no flags Details | Diff

  None (edit)
Description Jóhann B. Guðmundsson 2013-08-20 13:45:41 EDT
Created attachment 788569 [details]
bashrc - show full hostname at command prompt

Description of problem:

With the introduction of machine slices we should start showing full hostname at login prompt and shell(s) for administration convenience


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2013-08-20 13:46:23 EDT
Created attachment 788570 [details]
cshrc - show full hostname at command prompt
Comment 2 Ondrej Vasik 2013-08-21 02:30:11 EDT
Sounds ok... thanks for suggestion.
Comment 3 Ondrej Vasik 2013-08-21 10:25:03 EDT
Thinking a bit more about this change and I don't think this is a good default. Full hostname can be pretty long - and I'm quite sure there will be disappointed users after such change. Can you please bring this up on Fedora devel list so we can have wider audience? (Personally, I prefer the shorter hostname)
Comment 4 Jóhann B. Guðmundsson 2013-08-21 10:32:45 EDT
(In reply to Ondrej Vasik from comment #3)
> Thinking a bit more about this change and I don't think this is a good
> default. Full hostname can be pretty long - and I'm quite sure there will be
> disappointed users after such change. Can you please bring this up on Fedora
> devel list so we can have wider audience? (Personally, I prefer the shorter
> hostname)

Hmm how otherwise are you going to distinguished logging and commant prompt from 1000 containers all starting with www.<foo> or ns1.<bar> or sql.<xyz> or *.

Dan talk about him and the other Dan ( libvirt ) spawned 8000 containers on a single 64GB host at flock so we are talking about some serious problem to be solve here.
Comment 5 Ondrej Vasik 2013-08-21 10:42:41 EDT
Yes, I can imagine the usecases for the long prompt - however it can be changed on user level in ~/.bashrc or ~/.cshrc file.
For common user, short prompt is usually just fine - I have usually only few ssh sessions and short hostname is enough there. With multiple containers, of course long name is better option (if the hostname is not too long).
Comment 6 Jóhann B. Guðmundsson 2013-08-21 14:51:23 EDT
Feedback requested here [1] for both defaulting to long hostname as well as setting empty root password.

1.https://lists.fedoraproject.org/pipermail/devel/2013-August/188107.html
Comment 7 Jóhann B. Guðmundsson 2013-08-22 17:08:43 EDT
FESCO ticket https://fedorahosted.org/fesco/ticket/1161
Comment 8 Ondrej Vasik 2013-08-29 05:28:19 EDT
As a side note - what about "compromise" proposal? Keeping short hostname in prompt, but adding long hostname to the header of the terminal (xterm,gnome-terminal, whatever...)? This could help differentiation and should be ok (unnoticed by common users).
Comment 9 Jóhann B. Guðmundsson 2013-09-03 15:01:26 EDT
(In reply to Ondrej Vasik from comment #8)
> As a side note - what about "compromise" proposal? Keeping short hostname in
> prompt, but adding long hostname to the header of the terminal
> (xterm,gnome-terminal, whatever...)? This could help differentiation and
> should be ok (unnoticed by common users).

Sorry for late response been on a archery contest in sweden

What you propose is not an option since the administrator might not be running "Fedora" to administrate "Fedora" as well as the fact that the short hostname is the problem and is something we should never have defaulted to.

So our options are either to remove it completely thus forcing administrators to run a command to figure out which servers or containers they are "in" or show full hostname and have administrators that do not want it manually overwrite it in their home directory.

The latter is better choice to default to since it helps the inexperienced administrators, as in the group that is more likely to a) not knowing how to edit bashrc or manually overwrite it and b) be prone to make mistakes on wrong server in the first place.

Note You need to log in before you can comment on or make changes to this bug.