Bug 9991 - 6.1.98 - partitioning
Summary: 6.1.98 - partitioning
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-05 21:15 UTC by Trond Eivind Glomsrød
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-12 11:41:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Trond Eivind Glomsrød 2000-03-05 21:15:20 UTC
I reinstalled a computer, with a hda with a win95 partition, two ext2 and a
swap partition and a hdb with a big win95 partition (which I deleted).

When installing, I chose everything and had a few partitions - including a
1400 MB / (this computer is going to be totally reinstalled in a couple of
weeks anyway). It complained about lack of space (bug? When I did almost
the same thing afterwards, the space requirement seemed to be about 1200
MB)- so I had to go back to the disk partitioning. This is a looong way - a
shortcut would have been nice (7.0). Anyway, I adjusted it to "use
available space", which should make about 2600 MB. This was on drive b.
When I got back to restarting the install, nothing  happened. Usually, this
meant something was wrong, but not with 6.2, so I just started doing other
things and came back later. It hadn't gotten any further, and on a VC (not
in the GUI) I found this:


Exception in Thread-3:
Traceback (innermost last):

        File "/usr/lib/python1.5/threading.py", line 376, in __bootstrap
                self.run()
        File "/usr/lib/anaconda/iw/progress.py", line 16, in run
                rc=self.todo.doInstall()
        File "/usr/lib/anaconda/todo.py", line 1103, in doInstall
                self.fstab.savePartitions()
        File "/usr/lib/anaconda/fstab.py", line 149, in SavePartitions
                self.ddruid.save()

SystemError: Error partitioning drive /tmp/hda: Invalid argument(*)

(*)The last two words are translated back from Norwegian.

Comment 1 Jay Turner 2000-03-06 12:36:59 UTC
There are some pretty strange things that were happening when going forward and
back during an installation, especially when trying to go back and modify the
partitioning.  This is probably what caused the problem you were seeing.  We
have made a number of changes in that area of the code since the public beta.  I
will try to recreate this in the lab, otherwise I will just assume that we fixed
this issue.

Comment 2 Trond Eivind Glomsrød 2000-03-06 13:11:59 UTC
As the summary says - this was 6.1.98(*), the snapshot released Saturday March
4th. This is not the public beta as you assumed, so I reopen the bug.

(*) Which wasn't an available choice in bugzilla

Comment 3 Jay Turner 2000-04-11 17:12:59 UTC
Does this problem still exist in the final release of 6.2??

Comment 4 Trond Eivind Glomsrxd 2000-04-11 17:57:59 UTC
Sorry, I didn't bring my computer with me to the US so I'm not able to test.


Note You need to log in before you can comment on or make changes to this bug.