Bug 999150 - [PATCH] Allow setting exclude/includepkgs for yum-cron
[PATCH] Allow setting exclude/includepkgs for yum-cron
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
All Linux
unspecified Severity low
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 15:59 EDT by jcpunk
Modified: 2013-10-21 15:20 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-21 15:20:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to implement behavior (1.48 KB, application/mbox)
2013-08-20 15:59 EDT, jcpunk
no flags Details

  None (edit)
Description jcpunk 2013-08-20 15:59:45 EDT
Created attachment 788629 [details]
Patch to implement behavior

Description of problem: I'd like a bit more control over how yum-cron pulls in updates.

I've got one system where I don't care what is updated, so long as it isn't a certian package set.  Those need to be tested against our applications first.  So I'd prefer to leave them to manual update.

I've got another system where I only want certian packages kept up to date, but not others unless there is some manual interaction.


Version-Release number of selected component (if applicable): 3.4.3-106.fc19


How reproducible: 100%


Steps to Reproduce:
1. Want to exclude some packages from autoupdate but not from manual update
2. Can't find an easy way in yum-cron
3.

Actual results:
No easy way

Expected results:
Some easy way to do this

Additional info:

Patch to implement behavior attached.
Couldn't login to the official yum bug tracker.
Comment 1 jcpunk 2013-10-21 15:20:44 EDT
Looks like this behavior exists in yum 3.4.3-111-fc19 :)

Note You need to log in before you can comment on or make changes to this bug.