Bug 999172 - Unit tests for ISO and ISOManifest are failing on RHEL 5
Unit tests for ISO and ISOManifest are failing on RHEL 5
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: iso-support (Show other bugs)
2.2
x86_64 Linux
high Severity high
: ---
: 2.2.0
Assigned To: Barnaby Court
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 17:01 EDT by Barnaby Court
Modified: 2014-03-18 12:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 12:06:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log of test failures (21.59 KB, text/plain)
2013-08-20 17:01 EDT, Barnaby Court
no flags Details

  None (edit)
Description Barnaby Court 2013-08-20 17:01:04 EDT
Created attachment 788655 [details]
log of test failures

Description of problem:  The unit tests for ISO & ISO Manifest are in the common models.  This is causing the tests to run on Python 2.4 on RHEL 5 where they are failing due to syntax errors.  The particular tests can be found in pulp_rpm/pulp_rpm/test/unit/test_common_models.py


Version-Release number of selected component (if applicable): 2.2 & Master


How reproducible:  Easily 


Steps to Reproduce:
1. Run the test suite on RHEL5
2. Inspect the log file for test failures

Actual results:
Unit tests fail on RHEL 5

Expected results:  All unit tests should pass on RHEL 5


Additional info:
Comment 1 Randy Barlow 2013-09-11 16:53:43 EDT
Since I am starting a sprint and others are working on bugs, I am removing this bug from my plate for now. If someone else wants to pick this up, the fix should be pretty simple:

All of the failing tests are using code that will only execute on the server and not on the client. It is a good argument that this code doesn't belong in pulp_rpm.common, however, the quick fix is to use our test skip decorator on the particular tests that are failing.
Comment 4 Jeff Ortel 2013-11-01 14:50:42 EDT
build: 2.2.1-0.1.beta
Comment 5 Barnaby Court 2013-11-19 11:04:43 EST
Nightly build for pulp-2.2 on RHEL 5 completed successfully with no unit test errors on Nov 19, 2013
Comment 6 Preethi Thomas 2014-03-18 12:06:24 EDT
These were already verified in the corresponding releases that they were fixed in. Moving them to closed current release.

Note You need to log in before you can comment on or make changes to this bug.