Bug 999235 - pulseaudio-2.1-6/alsa-lib-1.0.26: Residual tone after playing sounds (High-Pitched but low volume).
pulseaudio-2.1-6/alsa-lib-1.0.26: Residual tone after playing sounds (High-Pi...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 21:25 EDT by Davide Repetto
Modified: 2013-10-19 05:14 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-19 05:14:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Davide Repetto 2013-08-20 21:25:02 EDT
Description of problem:
=======================
After playing any kind of sound on an Asus M5A78L-M/USB3, pulseaudio does not completely switch off the sound.
It keeps playing a continuous stereo tone that is apparently related to the last few samples played, since the pitch changes dependig on the last sound played. The volume of the tone is low, but audible.
The problem happens both in Fedora 18 and Fedora 19 both with 32 and 64 bit os. 

The audio hardware on the asus M5A78L-M is:
00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA)
01:05.1 Audio device: Advanced Micro Devices [AMD] nee ATI RS780 HDMI Audio [Radeon HD 3000-3300 Series]

The problem does not present itsef on other audio hardware, namely I tried the very same OS on an Acer Aspire 5100, on an intel Desktop Board with builtin audio and on the same M5A78L-M with an addon card with no probelms, so it is probably limited to the specific sound chip present on this motherboard.

If pulseaudio is restarted, the tone stops as soon as puleaudio completes its initialization process. 



Version-Release number of selected component (if applicable):
=============================================================
pulseaudio-2.1-6.fc18 pulseaudio-2.1-6.fc19
Tested with 3.9.10/11 and 3.10.4/6/7 kernel

How reproducible:
=================
Always

Steps to Reproduce:
===================
1. Play audio
2. Stop audio

Actual results:
===============
Continuous beeeeeeeep :/ 

Expected results:
=================
Silence

Additional info:
================
The configuration tested is quite simple. No fancy stuff: the ATI RS780 HDMI Audio is disabled and a pair of normal stereo speakers are attached to the audio output on the mainboard.
Comment 1 Davide Repetto 2013-08-21 14:42:47 EDT
perhaps it is more appropriate for this bug to be filed against alsa?
Comment 2 Davide Repetto 2013-08-21 14:49:51 EDT
Post Scriptum:
after reading about everything google spits out about similar problems, today I experimented with various combinations of parameters of the snd_hda_intel module, unfortunately to no avail.
Comment 3 Davide Repetto 2013-08-21 17:24:03 EDT
Alsa-info output done from Fedora 18:
=====================================
http://www.alsa-project.org/db/?f=8bc3dbdd9d4e54e25656a4494c81cdb9626b704b
Comment 4 Davide Repetto 2013-08-21 17:41:46 EDT
Alsa-info output done from Fedora 19:
=====================================
http://www.alsa-project.org/db/?f=e55b7db185797bca30975370439e4caad070db06
Comment 5 Davide Repetto 2013-08-22 15:56:07 EDT
Out of curiosity today I put an oscilloscope at the audio Output, and I can confirm that the unwanted tone is present also while playing other sounds.
It is just not audible mostly because louder sounds will mask it.
You can still hear it though, if you play low volume samples or if you purposefully lower the volume while playing.
Comment 6 Davide Repetto 2013-10-19 05:14:23 EDT
Problem fixed in the current release of ALSA:
alsa-lib-1.0.27.2-1.fc19.i686

Note You need to log in before you can comment on or make changes to this bug.