Bug 999247 - SELinux is preventing /var/www/cgi-bin/cachemgr.cgi from 'read' accesses on the file /etc/squid/cachemgr.conf.
SELinux is preventing /var/www/cgi-bin/cachemgr.cgi from 'read' accesses on t...
Status: CLOSED DUPLICATE of bug 999229
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:0743d6d493ada622706377c24fd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 22:44 EDT by Nivag
Modified: 2013-08-22 09:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-22 09:23:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nivag 2013-08-20 22:44:44 EDT
Description of problem:
SELinux is preventing /var/www/cgi-bin/cachemgr.cgi from 'read' accesses on the file /etc/squid/cachemgr.conf.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that cachemgr.cgi should be allowed read access on the cachemgr.conf file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep cachemgr.cgi /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:httpd_sys_script_t:s0
Target Context                system_u:object_r:squid_conf_t:s0
Target Objects                /etc/squid/cachemgr.conf [ file ]
Source                        cachemgr.cgi
Source Path                   /var/www/cgi-bin/cachemgr.cgi
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           squid-3.2.13-1.fc19.x86_64
Policy RPM                    selinux-policy-3.12.1-69.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.10.7-200.fc19.x86_64 #1 SMP Thu
                              Aug 15 23:19:45 UTC 2013 x86_64 x86_64
Alert Count                   15
First Seen                    2013-08-21 13:28:08 NZST
Last Seen                     2013-08-21 13:59:31 NZST
Local ID                      5218d7af-b0dd-4fc5-885d-39193db86867

Raw Audit Messages
type=AVC msg=audit(1377050371.947:1173): avc:  denied  { read } for  pid=17234 comm="cachemgr.cgi" name="cachemgr.conf" dev="dm-1" ino=1198290 scontext=system_u:system_r:httpd_sys_script_t:s0 tcontext=system_u:object_r:squid_conf_t:s0 tclass=file


type=SYSCALL msg=audit(1377050371.947:1173): arch=x86_64 syscall=open success=no exit=EACCES a0=7f93015f1d58 a1=0 a2=1b6 a3=7f92ff57edc0 items=0 ppid=951 pid=17234 auid=4294967295 uid=48 gid=48 euid=48 suid=48 fsuid=48 egid=48 sgid=48 fsgid=48 ses=4294967295 tty=(none) comm=cachemgr.cgi exe=/var/www/cgi-bin/cachemgr.cgi subj=system_u:system_r:httpd_sys_script_t:s0 key=(null)

Hash: cachemgr.cgi,httpd_sys_script_t,squid_conf_t,file,read

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.7-200.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-08-22 09:23:34 EDT

*** This bug has been marked as a duplicate of bug 999229 ***

Note You need to log in before you can comment on or make changes to this bug.