Bug 999275 - librsync is not FIPS 140-2 complaint with MD5
librsync is not FIPS 140-2 complaint with MD5
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: librsync (Show other bugs)
18
x86_64 Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 01:14 EDT by Benjamin Kingston
Modified: 2013-08-21 03:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-21 03:50:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin Kingston 2013-08-21 01:14:18 EDT
Description of problem:
librsync seems to use MD5 which is unavailable in a FIPS environment. I am currently attempting to use duplicity (which uses librsync) which fails under FIPS.

Version-Release number of selected component (if applicable):
librsync-0.9.7-18

How reproducible:
Every time

Steps to Reproduce:
1.Enable FIPS in kernel
2.Run librsync dependant program such as duplicity
3.ValueError: error:060800A3:digital envelope routines:EVP_DigestInit_ex:disabled for fips

Actual results:
ValueError: error:060800A3:digital envelope routines:EVP_DigestInit_ex:disabled for fips

Expected results:
librsync detects FIPS environment or by default selects at least SHA-1, preferably SHA256

Additional info:
Comment 1 Benjamin Kingston 2013-08-21 03:50:25 EDT
NOTABUG. Found the issue is in duplicity directly.

Note You need to log in before you can comment on or make changes to this bug.